Plugins · crm-memberships · data as of 2026-11-04
Is CRM Memberships safe? Known vulnerabilities and latest version
- Latest version
- 2.9
- Last updated
- 2026-09-22
- Active installs
- fewer than 10
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
WordPress plugin for content protection, membership management, and CRM integration. Create courses, restrict content, and integrate with CRMs. — by dripadmin
What to do
- Update to the latest version (2.9). Anything older than 2.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get crm-memberships --field=version shows what you run; wp plugin update crm-memberships updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-13312 · published 2025-12-05
Missing authorization check in CRM Memberships (2.5 and older)
- Affected
- 2.5 and older
- Fixed in
- 2.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CRM Memberships plugin for WordPress is vulnerable to unauthorized membership tag creation due to a missing capability check on the 'ntzcrm_add_new_tag' function in all versions up to, and including, 2.5. This makes it possible for unauthenticated attackers to create arbitrary membership tags and modify CRM configuration that should be restricted to administrators.
critical 9.8 CVE-2025-13313 · published 2025-12-05
Privilege escalation in CRM Memberships (2.6 and older)
- Affected
- 2.6 and older
- Fixed in
- 2.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CRM Memberships plugin for WordPress is vulnerable to privilege escalation via password reset in all versions up to, and including, 2.6. This is due to missing authorization and authentication checks on the `ntzcrm_changepassword` AJAX action. This makes it possible for unauthenticated attackers to reset arbitrary user passwords and gain unauthorized access to user accounts via the `ntzcrm_changepassword` endpoint, granted they can obtain or enumerate a target user's email address. The plugin also exposes the `ntzcrm_get_users` endpoint without authentication, allowing attackers to enumerate subscriber email addresses, facilitating the exploitation of the password reset vulnerability.
NVD CVE-2025-13313Wordfence advisoryCode change (fix)Plugin source
medium 4.8 CVE-2023-27427 · published 2023-06-23
Stored cross-site scripting (XSS) in CRM Memberships (1.6 and older)
- Affected
- 1.6 and older
- Fixed in
- 2.0 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in NTZApps CRM Memberships plugin <= 1.6 versions.
Recent activity
- 2026-09-22 — latest release on wordpress.org (2.9).
- 2025-12-05 — Missing authorization check disclosed (CVE-2025-13312), fixed in 2.6.
- 2025-12-05 — Privilege escalation disclosed (CVE-2025-13313), fixed in 2.7.
- 2023-06-23 — Stored cross-site scripting (XSS) disclosed (CVE-2023-27427), fixed in 2.0.
Get an email when CRM Memberships has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for CRM Memberships (crm-memberships) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Privilege escalation (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/crm-memberships (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/crm-memberships"><img src="https://laskyr.com/plugins/crm-memberships/badge.svg" alt="CRM Memberships vulnerability status"></a>