Skip to content
Laskyr

Plugins · cp-multi-view-calendar · data as of 2026-11-04

Is CP Multi View Events Calendar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.44)

As of 2026-11-04. 7 issues are on record for older versions; version 1.4.44 or newer fixes all of them that state a fix.

Latest version
1.4.44
Last updated
2026-10-29
Active installs
900+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4

A powerful and flexible WordPress event calendar plugin that lets you display your events in multiple calendar views, just like Google Calendar. — by codepeople

What to do

  1. Update to the latest version (1.4.44). Anything older than 1.4.44 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cp-multi-view-calendar --field=version shows what you run; wp plugin update cp-multi-view-calendar updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-119176 · published 2026-10-30

Stored cross-site scripting (XSS) in CP Multi View Events Calendar (1.4.43 and older)

Affected
1.4.43 and older
Fixed in
1.4.44 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Subject' parameter in all versions up to, and including, 1.4.43 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The required nonce is localized to any published page carrying the calendar shortcode, making the adddetails endpoint reachable by any authenticated user with Subscriber-level access or above.

NVD CVE-2026-119176Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2026-110701 · published 2026-10-16

Stored cross-site scripting (XSS) in CP Multi View Events Calendar (1.4.42 and older)

Affected
1.4.42 and older
Fixed in
1.4.43 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'CalendarTitle' parameter in all versions up to, and including, 1.4.42 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires that an administrator has enabled the "Allow edition in frontend?" option on at least one calendar view, which exposes the unauthenticated add endpoint and a publicly accessible nonce.

NVD CVE-2026-110701Wordfence advisoryCode change (fix)Plugin source

high 8.5 CVE-2026-109901 · published 2026-10-14

SQL injection in CP Multi View Events Calendar (1.4.41 and older)

Affected
1.4.41 and older
Fixed in
1.4.42
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Codepeople CP Multi View Event Calendar cp-multi-view-calendar allows SQL Injection.This issue affects CP Multi View Event Calendar : from n/a through 1.4.41.

NVD CVE-2026-109901Patchstack advisory

medium 6.5 CVE-2026-25465 · published 2026-03-25

Stored cross-site scripting (XSS) in CP Multi View Events Calendar (1.4.36 and older)

Affected
1.4.36 and older
Fixed in
1.4.37 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in codepeople CP Multi View Event Calendar cp-multi-view-calendar allows Stored XSS.This issue affects CP Multi View Event Calendar : from n/a through <= 1.4.36.

NVD CVE-2026-25465Patchstack advisory

low 3.8 CVE-2025-58009 · published 2025-09-22

Missing authorization check in CP Multi View Events Calendar (1.4.35 and older)

Affected
1.4.35 and older
Fixed in
1.4.36 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in codepeople CP Multi View Event Calendar cp-multi-view-calendar allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CP Multi View Event Calendar : from n/a through <= 1.4.35.

NVD CVE-2025-58009Patchstack advisory

low 3.8 CVE-2023-23814 · published 2024-12-09

Missing authorization check in CP Multi View Events Calendar (1.4.13 and older)

Affected
1.4.13 and older
Fixed in
1.4.15
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CodePeople CP Multi View Event Calendar allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CP Multi View Event Calendar : from n/a through 1.4.13.

NVD CVE-2023-23814Patchstack advisory

medium 4.3 CVE-2023-28492 · published 2024-06-03

Missing authorization check in CP Multi View Events Calendar (1.4.10 and older)

Affected
1.4.10 and older
Fixed in
1.4.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CodePeople CP Multi View Event Calendar allows Functionality Misuse.This issue affects CP Multi View Event Calendar: from n/a through 1.4.10.

NVD CVE-2023-28492Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CP Multi View Events Calendar vulnerability status badge
<a href="https://laskyr.com/plugins/cp-multi-view-calendar"><img src="https://laskyr.com/plugins/cp-multi-view-calendar/badge.svg" alt="CP Multi View Events Calendar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit