Skip to content
Laskyr

Plugins · cp-contact-form-with-paypal · data as of 2026-11-04

Is CP Contact Form with PayPal safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.70)

As of 2026-11-04. 8 issues are on record for older versions; version 1.3.62 or newer fixes all of them that state a fix.

Latest version
1.3.70
Last updated
2026-10-28
Active installs
800+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4

Easily create contact forms with integrated PayPal payments. Accept service payments, orders, and more with a drag-and-drop form builder. — by codepeople

What to do

  1. Update to the latest version (1.3.70). Anything older than 1.3.62 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cp-contact-form-with-paypal --field=version shows what you run; wp plugin update cp-contact-form-with-paypal updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.5 CVE-2026-32433 · published 2026-03-13

SQL injection in CP Contact Form with PayPal (1.3.61 and older)

Affected
1.3.61 and older
Fixed in
1.3.62
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in codepeople CP Contact Form with Paypal cp-contact-form-with-paypal allows Blind SQL Injection.This issue affects CP Contact Form with Paypal: from n/a through <= 1.3.61.

NVD CVE-2026-32433Patchstack advisory

high 7.5 CVE-2025-13384 · published 2025-11-22

Missing authorization check in CP Contact Form with PayPal (1.3.56 and older)

Affected
1.3.56 and older
Fixed in
1.3.57 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CP Contact Form with PayPal plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.3.56. This is due to the plugin exposing an unauthenticated IPN-like endpoint (via the 'cp_contactformpp_ipncheck' query parameter) that processes payment confirmations without any authentication, nonce verification, or PayPal IPN signature validation. This makes it possible for unauthenticated attackers to mark form submissions as paid without making actual payments by sending forged payment notification requests with arbitrary POST data (payment_status, txn_id, payer_email).

NVD CVE-2025-13384Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-13758 · published 2025-01-30

Cross-site request forgery (CSRF) in CP Contact Form with PayPal (1.3.52 and older)

Affected
1.3.52 and older
Fixed in
1.3.53 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The CP Contact Form with PayPal plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.3.52. This is due to missing or incorrect nonce validation on the cp_contact_form_paypal_check_init_actions() function. This makes it possible for unauthenticated attackers to add discount codes via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2024-13758Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 8.8 CVE-2023-27460 · published 2024-06-03

Missing authorization check in CP Contact Form with PayPal (1.3.34 and older)

Affected
1.3.34 and older
Fixed in
1.3.35
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in CodePeople, paypaldev CP Contact Form with Paypal allows Functionality Misuse.This issue affects CP Contact Form with Paypal: from n/a through 1.3.34.

NVD CVE-2023-27460Patchstack advisory

medium 6.1 CVE-2019-14784 · published 2019-08-15

Cross-site scripting (XSS) in CP Contact Form with PayPal (older than 1.2.98)

Affected
older than 1.2.98
Fixed in
1.2.98
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The "CP Contact Form with PayPal" plugin before 1.2.98 for WordPress has XSS in CSS edition.

NVD CVE-2019-14784wordpress.org

medium 5.4 CVE-2019-14785 · published 2019-08-09

Cross-site scripting (XSS) in CP Contact Form with PayPal (older than 1.2.99)

Affected
older than 1.2.99
Fixed in
1.2.99
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The "CP Contact Form with PayPal" plugin before 1.2.99 for WordPress has XSS in the publishing wizard via the wp-admin/admin.php?page=cp_contact_form_paypal.php&pwizard=1 cp_contactformpp_id parameter.

NVD CVE-2019-14785wordpress.orgpluginvulnerabilities.com

high 8.8 CVE-2015-9233 · published 2017-09-30

Cross-site request forgery (CSRF) in CP Contact Form with PayPal (older than 1.1.6)

Affected
older than 1.1.6
Fixed in
1.1.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The cp-contact-form-with-paypal (aka CP Contact Form with PayPal) plugin before 1.1.6 for WordPress has CSRF with resultant XSS, related to cp_contactformpp.php and cp_contactformpp_admin_int_list.inc.php.

NVD CVE-2015-9233wordpress.orgseclists.orgseclists.org

high 7.2 CVE-2015-9234 · published 2017-09-30

SQL injection in CP Contact Form with PayPal (1.1.5 and older)

Affected
1.1.5 and older
Fixed in
1.3.11 *
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

The cp-contact-form-with-paypal (aka CP Contact Form with PayPal) plugin before 1.1.6 for WordPress has SQL injection via the cp_contactformpp_id parameter to cp_contactformpp.php.

NVD CVE-2015-9234wordpress.orgseclists.orgseclists.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CP Contact Form with PayPal vulnerability status badge
<a href="https://laskyr.com/plugins/cp-contact-form-with-paypal"><img src="https://laskyr.com/plugins/cp-contact-form-with-paypal/badge.svg" alt="CP Contact Form with PayPal vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit