Skip to content
Laskyr

Plugins · course-booking-system · data as of 2026-11-04

Is Course Booking System safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.1.2)

As of 2026-11-04. 5 issues are on record for older versions; version 7.1 or newer fixes all of them that state a fix.

Latest version
7.1.2
Last updated
2026-10-25
Active installs
80+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.2 · PHP 7.0+

Individual course booking system for recurring events and specific needs. — by ComMotion

What to do

  1. Update to the latest version (7.1.2). Anything older than 7.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get course-booking-system --field=version shows what you run; wp plugin update course-booking-system updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-96886 · published 2026-09-30

Information disclosure in Course Booking System (7.0 up to (not including) 7.0.9)

Affected
7.0 up to (not including) 7.0.9
Fixed in
7.0.9
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Course Booking System WordPress plugin before 7.0.9 does not restrict access to its booking export, allowing unauthenticated users to download the name, email address and billing address of every customer who has booked a course.

NVD CVE-2026-96886WPScan advisory

medium 5.3 CVE-2025-12042 · published 2025-11-08

Missing authorization check in Course Booking System (6.1.5 and older)

Affected
6.1.5 and older
Fixed in
7.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Course Booking System plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check in the csv-export.php file in all versions up to, and including, 6.1.5. This makes it possible for unauthenticated attackers to directly access the file and obtain an export of all booking data.

NVD CVE-2025-12042Wordfence advisoryCode change (fix)

high 7.1 CVE-2025-32508 · published 2025-04-17

Reflected cross-site scripting (XSS) in Course Booking System (6.1.2 and older)

Affected
6.1.2 and older
Fixed in
6.1.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ComMotion Course Booking System course-booking-system allows Reflected XSS.This issue affects Course Booking System: from n/a through <= 6.1.2.

NVD CVE-2025-32508Patchstack advisory

medium 5.3 CVE-2025-32253 · published 2025-04-04

Missing authorization check in Course Booking System (6.1 and older)

Affected
6.1 and older
Fixed in
6.1.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ComMotion Course Booking System course-booking-system allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Course Booking System: from n/a through <= 6.1.

NVD CVE-2025-32253Patchstack advisory

critical 9.3 CVE-2025-22785 · published 2025-01-15

SQL injection in Course Booking System (6.0.6 and older)

Affected
6.0.6 and older
Fixed in
6.0.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in ComMotion Course Booking System course-booking-system allows SQL Injection.This issue affects Course Booking System: from n/a through <= 6.0.6.

NVD CVE-2025-22785Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Course Booking System vulnerability status badge
<a href="https://laskyr.com/plugins/course-booking-system"><img src="https://laskyr.com/plugins/course-booking-system/badge.svg" alt="Course Booking System vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit