Skip to content
Laskyr

Plugins · counter-box · data as of 2026-11-04

Is Counter Box safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.14)

As of 2026-11-04. 6 issues are on record for older versions; version 2.0.14 or newer fixes all of them that state a fix.

Latest version
2.0.14
Last updated
2026-08-25
Active installs
1,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Easily add countdowns, timers, and counters to your WordPress site. Ideal for sales, events, stats, and personalized time-based experiences. — by Wow-Company

What to do

  1. Update to the latest version (2.0.14). Anything older than 2.0.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get counter-box --field=version shows what you run; wp plugin update counter-box updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.6 CVE-2026-12115 · published 2026-06-17

PHP object injection in Counter Box (2.0.13 and older)

Affected
2.0.13 and older
Fixed in
2.0.14 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Counter Box – Add Countdowns, Timers & Dynamic Counters to WordPress plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.0.13 via deserialization of untrusted input . This makes it possible for authenticated attackers, with administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present. Deserialization is triggered automatically upon the post-import redirect that renders the list table, and again when any item is opened for editing, requiring no additional navigation beyond the import action itself.

NVD CVE-2026-12115Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2024-13901 · published 2025-03-01

Stored cross-site scripting (XSS) in Counter Box (2.0.6 and older)

Affected
2.0.6 and older
Fixed in
2.0.7 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Counter Box: Add Engaging Countdowns, Timers & Counters to Your WordPress Site plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via the ‘content’ parameter in all versions up to, and including, 2.0.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2024-13901Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2025-24715 · published 2025-01-24

Cross-site request forgery (CSRF) in Counter Box (2.0.5 and older)

Affected
2.0.5 and older
Fixed in
2.0.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Wow-Company Counter Box counter-box allows Cross Site Request Forgery.This issue affects Counter Box: from n/a through <= 2.0.5.

NVD CVE-2025-24715Patchstack advisory

medium 5.2 CVE-2024-3481 · published 2024-05-02

Cross-site request forgery (CSRF) in Counter Box (older than 1.2.4)

Affected
older than 1.2.4
Fixed in
1.2.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Counter Box WordPress plugin before 1.2.4 does not have CSRF checks in some bulk actions, which could allow attackers to make logged in admins perform unwanted actions, such deleting counters via CSRF attacks

NVD CVE-2024-3481WPScan advisory

high 8.8 CVE-2022-2245 · published 2022-08-01

Cross-site request forgery (CSRF) in Counter Box (older than 1.2.1)

Affected
older than 1.2.1
Fixed in
1.2.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The Counter Box WordPress plugin before 1.2.1 is lacking CSRF check when activating and deactivating counters, which could allow attackers to make a logged in admin perform such actions via CSRF attacks

NVD CVE-2022-2245WPScan advisory

high 7.2 CVE-2022-29446 · published 2022-05-19

File inclusion in Counter Box (1.1.1 and older)

Affected
1.1.1 and older
Fixed in
1.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authenticated (administrator or higher role) Local File Inclusion (LFI) vulnerability in Wow-Company's Counter Box plugin <= 1.1.1 at WordPress.

NVD CVE-2022-29446Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Counter Box vulnerability status badge
<a href="https://laskyr.com/plugins/counter-box"><img src="https://laskyr.com/plugins/counter-box/badge.svg" alt="Counter Box vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit