Skip to content
Laskyr

Plugins · countdown-for-the-events-calendar · data as of 2026-11-04

Is Event Countdown for The Events Calendar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.1)

As of 2026-11-04. 2 issues are on record for older versions; version 1.4.16 or newer fixes all of them that state a fix.

Latest version
2.0.1
Last updated
2026-09-01
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Event countdown timer for The Events Calendar. Show a countdown to upcoming events with a shortcode, block, Elementor widget or sticky floating bar. — by Narinder Singh

What to do

  1. Update to the latest version (2.0.1). Anything older than 1.4.16 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get countdown-for-the-events-calendar --field=version shows what you run; wp plugin update countdown-for-the-events-calendar updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-69348 · published 2026-01-06

Missing authorization check in Event Countdown for The Events Calendar (1.4.15 and older)

Affected
1.4.15 and older
Fixed in
1.4.16
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CoolHappy The Events Calendar Countdown Addon countdown-for-the-events-calendar allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects The Events Calendar Countdown Addon: from n/a through <= 1.4.15.

NVD CVE-2025-69348Patchstack advisory

medium 6.5 CVE-2025-49311 · published 2025-06-06

Stored cross-site scripting (XSS) in Event Countdown for The Events Calendar (1.4.9 and older)

Affected
1.4.9 and older
Fixed in
1.4.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CoolHappy The Events Calendar Countdown Addon countdown-for-the-events-calendar allows Stored XSS.This issue affects The Events Calendar Countdown Addon: from n/a through <= 1.4.9.

NVD CVE-2025-49311Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Event Countdown for The Events Calendar vulnerability status badge
<a href="https://laskyr.com/plugins/countdown-for-the-events-calendar"><img src="https://laskyr.com/plugins/countdown-for-the-events-calendar/badge.svg" alt="Event Countdown for The Events Calendar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit