Skip to content
Laskyr

Plugins · cost-of-goods-for-woocommerce · data as of 2026-11-04

Is Cost of Goods safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.2.3)

As of 2026-11-04. 5 issues are on record for older versions; version 4.2.1 or newer fixes all of them that state a fix.

Latest version
4.2.3
Last updated
2026-10-02
Active installs
9,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Calculate COGS & profit margins, unlock detailed insights into product profitability, and get better financial analytics with our COGS plugin — by WPFactory

What to do

  1. Update to the latest version (4.2.3). Anything older than 4.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cost-of-goods-for-woocommerce --field=version shows what you run; wp plugin update cost-of-goods-for-woocommerce updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-93771 · published 2026-09-30

PHP object injection in Cost of Goods (3.5.2 and older)

Affected
3.5.2 and older
Fixed in
4.2.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager PHP Object Injection in Cost of Goods for WooCommerce <= 3.5.2 versions.

NVD CVE-2026-93771Patchstack advisory

medium 6.4 CVE-2026-6962 · published 2026-05-13

Stored cross-site scripting (XSS) in Cost of Goods (4.1.0 and older)

Affected
4.1.0 and older
Fixed in
4.1.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Cost of Goods: Product Cost & Profit Calculator for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'alg_wc_cog_product_cost' and 'alg_wc_cog_product_profit' shortcodes in all versions up to, and including, 4.1.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-6962Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-48240 · published 2025-05-19

Stored cross-site scripting (XSS) in Cost of Goods (3.7.0 and older)

Affected
3.7.0 and older
Fixed in
3.7.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPFactory Cost of Goods for WooCommerce cost-of-goods-for-woocommerce allows Stored XSS.This issue affects Cost of Goods for WooCommerce: from n/a through <= 3.7.0.

NVD CVE-2025-48240Patchstack advisory

medium 5.4 CVE-2023-23868 · published 2024-12-09

Missing authorization check in Cost of Goods (2.8.6 and older)

Affected
2.8.6 and older
Fixed in
2.8.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPFactory Cost of Goods for WooCommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Cost of Goods for WooCommerce: from n/a through 2.8.6.

NVD CVE-2023-23868Patchstack advisory

medium 6.1 CVE-2024-0821 · published 2024-02-29

Reflected cross-site scripting (XSS) in Cost of Goods (3.2.8 and older)

Affected
3.2.8 and older
Fixed in
3.2.9 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Cost of Goods Sold (COGS): Cost & Profit Calculator for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'section' parameter in all versions up to, and including, 3.2.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-0821Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Cost of Goods vulnerability status badge
<a href="https://laskyr.com/plugins/cost-of-goods-for-woocommerce"><img src="https://laskyr.com/plugins/cost-of-goods-for-woocommerce/badge.svg" alt="Cost of Goods vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit