Plugins · corvuspay-woocommerce-integration · data as of 2026-11-04
Is CorvusPay WooCommerce Payment Gateway safe? Known vulnerabilities and latest version
- Latest version
- 2.7.7
- Last updated
- 2026-10-13
- Active installs
- 1,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
CorvusPay WooCommerce Payment Gateway provides a completely integrated checkout experience between WooCommerce and CorvusPay. — by corvuspay
What to do
- Update to the latest version (2.7.7). Anything older than 2.7.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get corvuspay-woocommerce-integration --field=version shows what you run; wp plugin update corvuspay-woocommerce-integration updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-6939 · published 2026-07-11
Stored cross-site scripting (XSS) in CorvusPay WooCommerce Payment Gateway (2.7.4 and older)
- Affected
- 2.7.4 and older
- Fixed in
- 2.7.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CorvusPay WooCommerce Payment Gateway plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'approval_code' parameter in all versions up to, and including, 2.7.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The unauthenticated REST endpoint POST /wp-json/corvuspay/success/ is registered with permission_callback set to __return_true, and although a signature validation step exists it only logs the result without halting execution, meaning an attacker can supply a completely arbitrary signature and have a malicious approval_code stored in the database unchallenged.
NVD CVE-2026-6939Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-9027 · published 2026-07-09
Security issue in CorvusPay WooCommerce Payment Gateway (2.7.4 and older)
- Affected
- 2.7.4 and older
- Fixed in
- 2.7.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CorvusPay WooCommerce Payment Gateway plugin for WordPress is vulnerable to Payment Bypass via Improper Verification of Cryptographic Signature in all versions up to, and including, 2.7.4. The `corvuspay_success_handler` function registers the REST endpoint `POST /wp-json/corvuspay/success/` with `'permission_callback' => '__return_true'`, and while it calls `$this->client->validate->signature()` and stores the boolean result in `$res`, the result is never evaluated in a conditional — it is only written to the debug log — causing execution to unconditionally reach `$order->payment_complete()` regardless of whether the cryptographic signature is valid. This makes it possible for unauthenticated attackers to mark any pending WooCommerce order as fully paid by sending a POST request to the success endpoint containing an arbitrary or forged signature value, allowing them to obtain goods or services without payment. Because WooCommerce order IDs are sequential integers, target orders are trivially enumerable via the `order_number` POST parameter, requiring no prior knowledge of the victim order.
NVD CVE-2026-9027Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-9028 · published 2026-07-09
Missing authorization check in CorvusPay WooCommerce Payment Gateway (2.7.4 and older)
- Affected
- 2.7.4 and older
- Fixed in
- 2.7.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CorvusPay WooCommerce Payment Gateway plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.7.4. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to cancel any WooCommerce order placed via the CorvusPay payment method by supplying an arbitrary order number to the /wp-json/corvuspay/cancel/ REST endpoint.
NVD CVE-2026-9028Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2026-56029 · published 2026-06-26
Authentication bypass in CorvusPay WooCommerce Payment Gateway (2.7.4 and older)
- Affected
- 2.7.4 and older
- Fixed in
- 2.7.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Authentication in CorvusPay WooCommerce Payment Gateway <= 2.7.4 versions.
Recent activity
- 2026-10-13 — latest release on wordpress.org (2.7.7).
- 2026-07-11 — Stored cross-site scripting (XSS) disclosed (CVE-2026-6939), fixed in 2.7.5.
- 2026-07-09 — Security issue disclosed (CVE-2026-9027), fixed in 2.7.5.
- 2026-07-09 — Missing authorization check disclosed (CVE-2026-9028), fixed in 2.7.5.
Get an email when CorvusPay WooCommerce Payment Gateway has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for CorvusPay WooCommerce Payment Gateway (corvuspay-woocommerce-integration) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/corvuspay-woocommerce-integration (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/corvuspay-woocommerce-integration"><img src="https://laskyr.com/plugins/corvuspay-woocommerce-integration/badge.svg" alt="CorvusPay WooCommerce Payment Gateway vulnerability status"></a>