Skip to content
Laskyr

Plugins · coreactivity · data as of 2026-11-04

Is coreActivity safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.1)

As of 2026-11-04. 3 issues are on record for older versions; version 3.1 or newer fixes all of them that state a fix.

Latest version
3.1.1
Last updated
2026-07-17
Active installs
10+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.0+

Monitor and log all kinds of activity happening on the WordPress website, with fine control over events to log, detailed log and events panels... — by Milan Petrovic

What to do

  1. Update to the latest version (3.1.1). Anything older than 3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get coreactivity --field=version shows what you run; wp plugin update coreactivity updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-7635 · published 2026-05-13

PHP object injection in coreActivity (3.0 and older)

Affected
3.0 and older
Fixed in
3.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The coreActivity: Activity Logging for WordPress plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.0. This is due to the plugin failing to validate or strip PHP serialization syntax from the User-Agent HTTP header before storing it in the logmeta table, and subsequently calling `maybe_unserialize()` on every retrieved `meta_value` in `query_metas()` without verifying the data was originally serialized by the application. This makes it possible for unauthenticated attackers to inject a crafted PHP serialized payload via the User-Agent header during any logged event (such as a failed login attempt), which, when an administrator views the Logs page, is deserialized and passed to `DeviceDetector::setUserAgent()`, triggering a Fatal TypeError that creates a persistent Denial of Service condition blocking administrator access to the Logs page entirely.

NVD CVE-2026-7635Wordfence advisorygithub.comPlugin source

high 8.8 CVE-2024-0852 · published 2025-05-15

Stored cross-site scripting (XSS) in coreActivity (older than 1.8.1)

Affected
older than 1.8.1
Fixed in
1.8.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The coreActivity: Activity Logging for WordPress plugin before 1.8.1 does not escape some request data when outputting it back in the admin dashboard, allowing unauthenticated users to perform Stored XSS attack against high privilege users such as admin

NVD CVE-2024-0852WPScan advisory

medium 6.5 CVE-2025-3436 · published 2025-04-08

SQL injection in coreActivity (2.7 and older)

Affected
2.7 and older
Fixed in
2.7.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The coreActivity: Activity Logging for WordPress plugin for WordPress is vulnerable to SQL Injection via the 'order' and 'orderby' parameters in all versions up to, and including, 2.7 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-3436Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
coreActivity vulnerability status badge
<a href="https://laskyr.com/plugins/coreactivity"><img src="https://laskyr.com/plugins/coreactivity/badge.svg" alt="coreActivity vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit