Skip to content
Laskyr

Plugins · copyscape-premium · data as of 2026-11-04

Is Copyscape Premium safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.2)

As of 2026-11-04. 2 issues are on record for older versions; version 1.4.2 or newer fixes all of them that state a fix.

Latest version
1.4.2
Last updated
2025-12-24
Active installs
700+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

The Copyscape Premium plugin lets you check if a WordPress post is unique before it's published, by searching for duplicate content on the web. — by Copyscape

What to do

  1. Update to the latest version (1.4.2). Anything older than 1.4.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get copyscape-premium --field=version shows what you run; wp plugin update copyscape-premium updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-24966 · published 2026-02-03

Cross-site request forgery (CSRF) in Copyscape Premium (1.4.1 and older)

Affected
1.4.1 and older
Fixed in
1.4.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Copyscape Copyscape Premium copyscape-premium allows Cross Site Request Forgery.This issue affects Copyscape Premium: from n/a through <= 1.4.1.

NVD CVE-2026-24966Patchstack advisory

high 7.1 CVE-2024-47644 · published 2024-10-05

Stored cross-site scripting (XSS) in Copyscape Premium (1.3.9 and older)

Affected
1.3.9 and older
Fixed in
1.4.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Copyscape Copyscape Premium copyscape-premium allows Stored XSS.This issue affects Copyscape Premium: from n/a through <= 1.3.9.

NVD CVE-2024-47644Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Copyscape Premium vulnerability status badge
<a href="https://laskyr.com/plugins/copyscape-premium"><img src="https://laskyr.com/plugins/copyscape-premium/badge.svg" alt="Copyscape Premium vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit