Skip to content
Laskyr

Plugins · copy-delete-posts · data as of 2026-11-01

Is Duplicate Post safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.7)

As of 2026-11-01. 7 issues are on record for older versions; version 1.5.7 or newer fixes all of them that state a fix.

Latest version
1.5.7
Last updated
2026-09-23
Active installs
300,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Duplicate post — by Inisev

What to do

  1. Update to the latest version (1.5.7). Anything older than 1.5.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get copy-delete-posts --field=version shows what you run; wp plugin update copy-delete-posts updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-89424 · published 2026-10-01

Stored cross-site scripting (XSS) in Duplicate Post (1.5.6 and older)

Affected
1.5.6 and older
Fixed in
1.5.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Duplicate Post plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'noti_token' parameter in all versions up to, and including, 1.5.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires that the site owner has enabled the plugin's User Level Permissions for the Subscriber role, as this grants access to the i_saw_this_noti AJAX branch needed to deliver the payload.

NVD CVE-2026-89424Wordfence advisoryCode change (fix)Plugin source

low 2.7 CVE-2026-19085 · published 2026-08-21

Missing authorization check in Duplicate Post (older than 1.5.6)

Affected
older than 1.5.6
Fixed in
1.5.6
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Duplicate Post WordPress plugin before 1.5.6 does not check that a user may read the content of a post before duplicating it, allowing users with a delegated role to republish another user's password-protected post as publicly readable.

NVD CVE-2026-19085WPScan advisory

low 2.7 CVE-2026-19435 · published 2026-08-21

Missing authorization check in Duplicate Post (older than 1.5.6)

Affected
older than 1.5.6
Fixed in
1.5.6
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Duplicate Post WordPress plugin before 1.5.6 does not check the user's capabilities before returning post data, allowing users with a delegated role to read the content, metadata and passwords of posts they are not allowed to access, including other users' private and draft content.

NVD CVE-2026-19435WPScan advisory

medium 6.5 CVE-2026-19077 · published 2026-08-10

Missing authorization check in Duplicate Post (older than 1.5.5)

Affected
older than 1.5.5
Fixed in
1.5.5
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Duplicate Post WordPress plugin before 1.5.5 does not perform per-object authorisation checks in its bulk copy and delete operations, allowing any user whose role an administrator has granted Duplicate Post WordPress plugin before 1.5.5 access to permanently delete arbitrary posts on the site, including those belonging to other users.

NVD CVE-2026-19077WPScan advisory

medium 4.3 CVE-2023-3977 · published 2023-07-28

Cross-site request forgery (CSRF) in Duplicate Post (1.3.9 and older)

Affected
1.3.9 and older
Fixed in
1.4.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Several plugins for WordPress by Inisev are vulnerable to Cross-Site Request Forgery to unauthorized installation of plugins due to a missing nonce check on the handle_installation function that is called via the inisev_installation AJAX aciton in various versions. This makes it possible for unauthenticated attackers to install plugins from the limited list via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2023-3977Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2023-0958 · published 2023-07-28

Missing authorization check in Duplicate Post (1.3.9 and older)

Affected
1.3.9 and older
Fixed in
1.4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Several plugins for WordPress by Inisev are vulnerable to unauthorized installation of plugins due to a missing capability check on the handle_installation function that is called via the inisev_installation AJAX aciton in various versions. This makes it possible for authenticated attackers with minimal permissions, such as subscribers, to install select plugins from Inisev on vulnerable sites. CVE-2023-38514 appears to be a duplicate of this vulnerability.

NVD CVE-2023-0958Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2021-43408 · published 2021-11-19

SQL injection in Duplicate Post (older than 1.2.0)

Affected
older than 1.2.0
Fixed in
1.2.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The "Duplicate Post" WordPress plugin up to and including version 1.1.9 is vulnerable to SQL Injection. SQL injection vulnerabilities occur when client supplied data is included within an SQL Query insecurely. SQL Injection can typically be exploited to read, modify and delete SQL table data. In many cases it also possible to exploit features of SQL server to execute system commands and/or access the local file system. This particular vulnerability can be exploited by any authenticated user who has been granted access to use the Duplicate Post plugin. By default, this is limited to Administrators, however the plugin presents the option to permit access to the Editor, Author, Contributor and Subscriber roles.

NVD CVE-2021-43408appcheck-ng.comPlugin source

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Duplicate Post vulnerability status badge
<a href="https://laskyr.com/plugins/copy-delete-posts"><img src="https://laskyr.com/plugins/copy-delete-posts/badge.svg" alt="Duplicate Post vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit