Skip to content
Laskyr

Plugins · cookies-and-content-security-policy · data as of 2026-11-04

Is Cookies and Content Security Policy safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.41)

As of 2026-11-04. 2 issues are on record for older versions; version 2.35 or newer fixes all of them that state a fix.

Latest version
2.41
Last updated
2026-08-25
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Be fully GDPR and CCPA compliant through Content Security Policy. Blocks cookies and unwanted external content. — by Johan Jonk Stenström

What to do

  1. Update to the latest version (2.41). Anything older than 2.35 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cookies-and-content-security-policy --field=version shows what you run; wp plugin update cookies-and-content-security-policy updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-63019 · published 2026-01-22

Information disclosure in Cookies and Content Security Policy (2.34 and older)

Affected
2.34 and older
Fixed in
2.35
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Johan Jonk Stenström Cookies and Content Security Policy cookies-and-content-security-policy allows Retrieve Embedded Sensitive Data.This issue affects Cookies and Content Security Policy: from n/a through <= 2.34.

NVD CVE-2025-63019Patchstack advisory

high 7.5 CVE-2023-40662 · published 2023-11-30

Information disclosure in Cookies and Content Security Policy (2.15 and older)

Affected
2.15 and older
Fixed in
2.16
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Jonk @ Follow me Darling Cookies and Content Security Policy.This issue affects Cookies and Content Security Policy: from n/a through 2.15.

NVD CVE-2023-40662Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Cookies and Content Security Policy vulnerability status badge
<a href="https://laskyr.com/plugins/cookies-and-content-security-policy"><img src="https://laskyr.com/plugins/cookies-and-content-security-policy/badge.svg" alt="Cookies and Content Security Policy vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit