Plugins · cookiebot · data as of 2026-11-04
Is Cookiebot safe? Known vulnerabilities and latest version
- Latest version
- 4.7.5
- Last updated
- 2026-10-29
- Active installs
- 100,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Automatic cookie banner and cookie notice for GDPR, CCPA & Google Consent Mode v2. Blocks cookies until consent. Free: 1 domain, up to 50 subpages. — by cookiebot
What to do
- Update to the latest version (4.7.5). Anything older than 4.6.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get cookiebot --field=version shows what you run; wp plugin update cookiebot updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-25407 · published 2026-02-19
Missing authorization check in Cookiebot (4.6.4 and older)
- Affected
- 4.6.4 and older
- Fixed in
- 4.6.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in cookiebot Cookiebot cookiebot allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Cookiebot: from n/a through <= 4.6.4.
medium 4.3 CVE-2025-53197 · published 2025-06-27
Cross-site request forgery (CSRF) in Cookiebot (4.5.8 and older)
- Affected
- 4.5.8 and older
- Fixed in
- 4.5.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in cookiebot Cookiebot cookiebot allows Cross Site Request Forgery.This issue affects Cookiebot: from n/a through <= 4.5.8.
medium 4.3 CVE-2025-1666 · published 2025-03-06
Missing authorization check in Cookiebot (4.4.1 and older)
- Affected
- 4.4.1 and older
- Fixed in
- 4.4.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Cookie banner plugin for WordPress – Cookiebot CMP by Usercentrics plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the send_uninstall_survey() function in all versions up to, and including, 4.4.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to submit the uninstall survey on behalf of a website.
NVD CVE-2025-1666Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-29 — latest release on wordpress.org (4.7.5).
- 2026-02-19 — Missing authorization check disclosed (CVE-2026-25407), fixed in 4.6.5.
- 2025-06-27 — Cross-site request forgery (CSRF) disclosed (CVE-2025-53197), fixed in 4.5.9.
- 2025-03-06 — Missing authorization check disclosed (CVE-2025-1666), fixed in 4.4.2.
Get an email when Cookiebot has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Cookiebot (cookiebot) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/cookiebot (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/cookiebot"><img src="https://laskyr.com/plugins/cookiebot/badge.svg" alt="Cookiebot vulnerability status"></a>