Skip to content
Laskyr

Plugins · cookie-notice-consent · data as of 2026-11-04

Is Cookie Notice & Consent safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.6)

As of 2026-11-04. 3 issues are on record for older versions; version 1.6.6 or newer fixes all of them that state a fix.

Latest version
1.6.6
Last updated
2025-10-06
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 7.2+

Display a cookie notice, collect consent for different categories and output scripts if consent is given. — by christophrado

What to do

  1. Update to the latest version (1.6.6). Anything older than 1.6.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cookie-notice-consent --field=version shows what you run; wp plugin update cookie-notice-consent updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2025-49390 · published 2025-11-06

Stored cross-site scripting (XSS) in Cookie Notice & Consent (1.6.4 and older)

Affected
1.6.4 and older
Fixed in
1.6.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in christophrado Cookie Notice & Consent cookie-notice-consent allows Stored XSS.This issue affects Cookie Notice & Consent: from n/a through <= 1.6.4.

NVD CVE-2025-49390Patchstack advisory

high 7.2 CVE-2025-10496 · published 2025-10-09

Stored cross-site scripting (XSS) in Cookie Notice & Consent (1.6.5 and older)

Affected
1.6.5 and older
Fixed in
1.6.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Cookie Notice & Consent plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the uuid parameter in all versions up to, and including, 1.6.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-10496Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2023-41948 · published 2023-09-25

Stored cross-site scripting (XSS) in Cookie Notice & Consent (1.6.0 and older)

Affected
1.6.0 and older
Fixed in
1.6.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Christoph Rado Cookie Notice & Consent plugin <= 1.6.0 versions.

NVD CVE-2023-41948Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Cookie Notice & Consent vulnerability status badge
<a href="https://laskyr.com/plugins/cookie-notice-consent"><img src="https://laskyr.com/plugins/cookie-notice-consent/badge.svg" alt="Cookie Notice & Consent vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit