Skip to content
Laskyr

Plugins · cookie-notice · data as of 2026-11-01

Is Cookie Compliance for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.17)

As of 2026-11-01. 4 issues are on record for older versions; version 2.5.9 or newer fixes all of them that state a fix.

Latest version
3.1.17
Last updated
2026-10-15
Active installs
800,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Consent management for WordPress — GDPR, CCPA & ePrivacy, autoblocking, Google Consent Mode, Microsoft Consent Mode (Pro), GPC & WP Consent API. — by Humanityco

What to do

  1. Update to the latest version (3.1.17). Anything older than 2.5.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cookie-notice --field=version shows what you run; wp plugin update cookie-notice updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2025-67554 · published 2025-12-09

Stored cross-site scripting (XSS) in Cookie Compliance for WordPress (2.5.8 and older)

Affected
2.5.8 and older
Fixed in
2.5.9
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Humanityco Cookie Notice & Compliance for GDPR / CCPA cookie-notice allows Stored XSS.This issue affects Cookie Notice & Compliance for GDPR / CCPA: from n/a through <= 2.5.8.

NVD CVE-2025-67554Patchstack advisory

medium 6.4 CVE-2025-11186 · published 2025-11-22

Stored cross-site scripting (XSS) in Cookie Compliance for WordPress (2.5.8 and older)

Affected
2.5.8 and older
Fixed in
2.5.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Cookie Notice & Compliance for GDPR / CCPA plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's cookies_accepted shortcode in all versions up to, and including, 2.5.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-11186Wordfence advisoryPlugin source

medium 4.4 CVE-2022-3399 · published 2024-08-16

Stored cross-site scripting (XSS) in Cookie Compliance for WordPress (2.4.17.1 and older)

Affected
2.4.17.1 and older
Fixed in
2.4.18 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Cookie Notice & Compliance for GDPR / CCPA plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'cookie_notice_options[refuse_code_head]' parameter in versions up to, and including, 2.4.17.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrative privileges and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the injected /wp-admin/admin.php?page=cookie-notice page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2022-3399Wordfence advisoryCode change (fix)

medium 5.4 CVE-2023-24400 · published 2023-05-07

Cross-site scripting (XSS) in Cookie Compliance for WordPress (2.4.6 and older)

Affected
2.4.6 and older
Fixed in
2.4.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Cross-Site Scripting (XSS) vulnerability in Hu-manity.Co Cookie Notice & Compliance for GDPR / CCPA plugin <= 2.4.6 versions.

NVD CVE-2023-24400Patchstack advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Cookie Compliance for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/cookie-notice"><img src="https://laskyr.com/plugins/cookie-notice/badge.svg" alt="Cookie Compliance for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit