Skip to content
Laskyr

Plugins · conveythis-translate · data as of 2026-11-04

Is ConveyThis AI Multilingual Translation safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (271.2)

As of 2026-11-04. 5 issues are on record for older versions; version 270.1 or newer fixes all of them that state a fix.

Latest version
271.2
Last updated
2026-10-20
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Translate WordPress into 200+ languages. AI translation plugin for multilingual websites — WooCommerce, SEO, hreflang, Google Translate. — by ConveyThis

What to do

  1. Update to the latest version (271.2). Anything older than 270.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get conveythis-translate --field=version shows what you run; wp plugin update conveythis-translate updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-68021 · published 2026-02-20

Missing authorization check in ConveyThis AI Multilingual Translation (269.9 and older)

Affected
269.9 and older
Fixed in
270.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ConveyThis ConveyThis conveythis-translate allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ConveyThis: from n/a through <= 269.9.

NVD CVE-2025-68021Patchstack advisory

medium 5.3 CVE-2025-62152 · published 2025-12-09

Missing authorization check in ConveyThis AI Multilingual Translation (269.2 and older)

Affected
269.2 and older
Fixed in
269.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ConveyThis ConveyThis conveythis-translate allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ConveyThis: from n/a through <= 269.2.

NVD CVE-2025-62152Patchstack advisory

high 7.2 CVE-2025-57919 · published 2025-09-22

PHP object injection in ConveyThis AI Multilingual Translation (269.1 and older)

Affected
269.1 and older
Fixed in
269.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in ConveyThis ConveyThis conveythis-translate allows Object Injection.This issue affects ConveyThis: from n/a through <= 269.1.

NVD CVE-2025-57919Patchstack advisory

medium 5.3 CVE-2024-38792 · published 2024-11-01

Missing authorization check in ConveyThis AI Multilingual Translation (234 and older)

Affected
234 and older
Fixed in
235
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ConveyThis Translate Team Language Translate Widget for WordPress – ConveyThis allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Language Translate Widget for WordPress – ConveyThis: from n/a through 234.

NVD CVE-2024-38792Patchstack advisory

high 7.2 CVE-2023-6811 · published 2024-04-11

Stored cross-site scripting (XSS) in ConveyThis AI Multilingual Translation (223 and older)

Affected
223 and older
Fixed in
239 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Language Translate Widget for WordPress – ConveyThis plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'api_key’ parameter in all versions up to, and including, 223 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-6811Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ConveyThis AI Multilingual Translation vulnerability status badge
<a href="https://laskyr.com/plugins/conveythis-translate"><img src="https://laskyr.com/plugins/conveythis-translate/badge.svg" alt="ConveyThis AI Multilingual Translation vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit