Skip to content
Laskyr

Plugins · convertkit-for-woocommerce · data as of 2026-11-04

Is Kit (formerly ConvertKit) for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.4)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2.1 or newer fixes all of them that state a fix.

Latest version
2.2.4
Last updated
2026-11-03
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Integrates WooCommerce with Kit allowing customers to be automatically sent to your Kit account. — by nathanbarry

What to do

  1. Update to the latest version (2.2.4). Anything older than 2.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get convertkit-for-woocommerce --field=version shows what you run; wp plugin update convertkit-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-105421 · published 2026-10-05

Missing authorization check in Kit (formerly ConvertKit) for WooCommerce (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
2.2.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Kit Kit (formerly ConvertKit) for WooCommerce convertkit-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Kit (formerly ConvertKit) for WooCommerce: from n/a through 2.2.0.

NVD CVE-2026-105421Patchstack advisory

medium 5.3 CVE-2026-57753 · published 2026-07-02

Information disclosure in Kit (formerly ConvertKit) for WooCommerce (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Sensitive Data Exposure in Kit (formerly ConvertKit) for WooCommerce <= 2.1.5 versions.

NVD CVE-2026-57753Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Kit (formerly ConvertKit) for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/convertkit-for-woocommerce"><img src="https://laskyr.com/plugins/convertkit-for-woocommerce/badge.svg" alt="Kit (formerly ConvertKit) for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit