Plugins · contest-code-checker · data as of 2026-11-04
Is Run Contests, Raffles, and Giveaways with Cont… safe? Known vulnerabilities and latest version
- Latest version
- 2.1.2
- Last updated
- 2026-10-26
- Active installs
- 90+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
An easy to use WordPress plugin to do giveaways. — by mdedev
What to do
- Update to the latest version (2.1.2). Anything older than 2.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get contest-code-checker --field=version shows what you run; wp plugin update contest-code-checker updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-25023 · published 2026-02-03
Information disclosure in Run Contests, Raffles, and Giveaways with Cont… (2.0.7 and older)
- Affected
- 2.0.7 and older
- Fixed in
- 2.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in mdedev Run Contests, Raffles, and Giveaways with ContestsWP contest-code-checker allows Retrieve Embedded Sensitive Data.This issue affects Run Contests, Raffles, and Giveaways with ContestsWP: from n/a through <= 2.0.7.
high 7.1 CVE-2025-32634 · published 2025-04-17
Reflected cross-site scripting (XSS) in Run Contests, Raffles, and Giveaways with Cont… (2.1.1 and older)
- Affected
- 2.1.1 and older
- Fixed in
- 2.1.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in mdedev Run Contests, Raffles, and Giveaways with ContestsWP contest-code-checker allows Reflected XSS.This issue affects Run Contests, Raffles, and Giveaways with ContestsWP: from n/a through <= 2.1.1.
medium 6.1 CVE-2024-11456 · published 2024-11-21
Reflected cross-site scripting (XSS) in Run Contests, Raffles, and Giveaways with Cont… (2.0.3 and older)
- Affected
- 2.0.3 and older
- Fixed in
- 2.0.5 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Run Contests, Raffles, and Giveaways with ContestsWP plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.0.3. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Recent activity
- 2026-10-26 — latest release on wordpress.org (2.1.2).
- 2026-02-03 — Information disclosure disclosed (CVE-2026-25023), fixed in 2.1.1.
- 2025-04-17 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-32634), fixed in 2.1.2.
- 2024-11-21 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-11456), fixed in 2.0.5.
Get an email when Run Contests, Raffles, and Giveaways with Cont… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Run Contests, Raffles, and Giveaways with Cont… (contest-code-checker) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/contest-code-checker (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/contest-code-checker"><img src="https://laskyr.com/plugins/contest-code-checker/badge.svg" alt="Run Contests, Raffles, and Giveaways with Cont… vulnerability status"></a>