Skip to content
Laskyr

Plugins · content-slideshow · data as of 2026-11-04

Is Content Slideshow safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5)

As of 2026-11-04. 1 issue is on record for older versions; version 2.5 or newer fixes all of them that state a fix.

Latest version
2.5
Last updated
2026-07-14
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8

This plugin creates a fullscreen slideshow that displays randomly-selected pictures from your media library. Designed to display pictures related to y … — by Nick Halsey

What to do

  1. Update to the latest version (2.5). Anything older than 2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get content-slideshow --field=version shows what you run; wp plugin update content-slideshow updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-8873 · published 2026-05-27

Stored cross-site scripting (XSS) in Content Slideshow (2.4.1 and older)

Affected
2.4.1 and older
Fixed in
2.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Content Slideshow plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Shortcode Attributes in all versions up to, and including, 2.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-8873Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Content Slideshow vulnerability status badge
<a href="https://laskyr.com/plugins/content-slideshow"><img src="https://laskyr.com/plugins/content-slideshow/badge.svg" alt="Content Slideshow vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit