Skip to content
Laskyr

Plugins · content-slider-block · data as of 2026-11-04

Is Content Slider Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.2)

As of 2026-11-04. 2 issues are on record for older versions; version 3.2.2 or newer fixes all of them that state a fix.

Latest version
3.2.2
Last updated
2026-10-26
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Power up your website with the Content Slider Block plugin. Easily create professional sliders using our new block editor integration! — by bPlugins

What to do

  1. Update to the latest version (3.2.2). Anything older than 3.2.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get content-slider-block --field=version shows what you run; wp plugin update content-slider-block updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-116398 · published 2026-10-26

Stored cross-site scripting (XSS) in Content Slider Block (3.2.1 and older)

Affected
3.2.1 and older
Fixed in
3.2.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Content Slider Block content-slider-block allows Stored XSS.This issue affects Content Slider Block: from n/a through 3.2.1.

NVD CVE-2026-116398Patchstack advisory

medium 4.3 CVE-2024-10667 · published 2024-11-09

Information disclosure in Content Slider Block (3.1.5 and older)

Affected
3.1.5 and older
Fixed in
3.1.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Content Slider Block plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 3.1.5 via the [csb] shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from password protected, private, or draft posts that they should not have access to.

NVD CVE-2024-10667Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Content Slider Block vulnerability status badge
<a href="https://laskyr.com/plugins/content-slider-block"><img src="https://laskyr.com/plugins/content-slider-block/badge.svg" alt="Content Slider Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit