Skip to content
Laskyr

Plugins · content-protector · data as of 2026-11-04

Is Passster safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.3.20)

As of 2026-11-04. 9 issues are on record for older versions; version 4.3.19 or newer fixes all of them that state a fix.

Latest version
4.3.20
Last updated
2026-10-23
Active installs
10,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Password Protect Pages, Posts & Content in WordPress — by WP Chill

What to do

  1. Update to the latest version (4.3.20). Anything older than 4.3.19 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get content-protector --field=version shows what you run; wp plugin update content-protector updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-110896 · published 2026-10-16

Missing authorization check in Passster (4.3.18 and older)

Affected
4.3.18 and older
Fixed in
4.3.19
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP Chill Passster content-protector allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Passster: from n/a through 4.3.18.

NVD CVE-2026-110896Patchstack advisory

medium 5.3 CVE-2026-62114 · published 2026-09-11

Missing authorization check in Passster (4.3.13 and older)

Affected
4.3.13 and older
Fixed in
4.3.14
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Passster <= 4.3.13 versions.

NVD CVE-2026-62114Patchstack advisory

medium 6.5 CVE-2026-25036 · published 2026-02-03

Missing authorization check in Passster (4.2.25 and older)

Affected
4.2.25 and older
Fixed in
4.2.26
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP Chill Passster content-protector allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Passster: from n/a through <= 4.2.25.

NVD CVE-2026-25036Patchstack advisory

medium 6.4 CVE-2025-14865 · published 2026-01-28

Stored cross-site scripting (XSS) in Passster (4.2.24 and older)

Affected
4.2.24 and older
Fixed in
4.2.25 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_protector' shortcode in all versions up to, and including, 4.2.24. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.2.21.

NVD CVE-2025-14865Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2025-64218 · published 2025-12-18

Information disclosure in Passster (4.2.19 and older)

Affected
4.2.19 and older
Fixed in
4.2.20
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in WP Chill Passster content-protector allows Retrieve Embedded Sensitive Data.This issue affects Passster: from n/a through <= 4.2.19.

NVD CVE-2025-64218Patchstack advisory

medium 6.5 CVE-2025-57926 · published 2025-09-22

Stored cross-site scripting (XSS) in Passster (4.2.18 and older)

Affected
4.2.18 and older
Fixed in
4.2.19
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Chill Passster content-protector allows Stored XSS.This issue affects Passster: from n/a through <= 4.2.18.

NVD CVE-2025-57926Patchstack advisory

high 7.5 CVE-2024-11282 · published 2025-01-07

Information disclosure in Passster (4.2.10 and older)

Affected
4.2.10 and older
Fixed in
4.2.11 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.10 via the WordPress core search feature. This makes it possible for unauthenticated attackers to extract sensitive data from posts that have been restricted to higher-level roles such as administrator.

NVD CVE-2024-11282Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-2026 · published 2024-04-09

Stored cross-site scripting (XSS) in Passster (4.2.6.4 and older)

Affected
4.2.6.4 and older
Fixed in
4.2.6.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Passster plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's content_protector shortcode in all versions up to, and including, 4.2.6.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2026Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2024-0616 · published 2024-02-29

Information disclosure in Passster (4.2.6.2 and older)

Affected
4.2.6.2 and older
Fixed in
4.2.6.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.6.2 via API. This makes it possible for unauthenticated attackers to obtain post titles, slugs, IDs, content and other metadata including passwords of password-protected posts and pages.

NVD CVE-2024-0616Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Passster vulnerability status badge
<a href="https://laskyr.com/plugins/content-protector"><img src="https://laskyr.com/plugins/content-protector/badge.svg" alt="Passster vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit