Skip to content
Laskyr

Plugins · content-control · data as of 2026-11-04

Is Content Control safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.4)

As of 2026-11-04. 5 issues are on record for older versions; version 2.6.6 or newer fixes all of them that state a fix.

Latest version
2.7.4
Last updated
2026-09-29
Active installs
40,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Restrict content based on login status, user roles, device type & more. Monetize your content with a paywall or members-only content. — by Daniel Iser

What to do

  1. Update to the latest version (2.7.4). Anything older than 2.6.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get content-control --field=version shows what you run; wp plugin update content-control updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-65485 · published 2026-07-23

Missing authorization check in Content Control (2.6.5 and older)

Affected
2.6.5 and older
Fixed in
2.6.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Content Control <= 2.6.5 versions.

NVD CVE-2026-65485Patchstack advisory

medium 6.5 CVE-2025-47501 · published 2025-05-07

Cross-site scripting (XSS) in Content Control (2.6.1 and older)

Affected
2.6.1 and older
Fixed in
2.6.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Daniel Iser Content Control content-control allows DOM-Based XSS.This issue affects Content Control: from n/a through <= 2.6.1.

NVD CVE-2025-47501Patchstack advisory

medium 5.3 CVE-2024-11153 · published 2025-03-05

Information disclosure in Content Control (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.6.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Content Control – The Ultimate Content Restriction Plugin! Restrict Content, Create Conditional Blocks & More plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.5.0 via the WordPress core search feature. This makes it possible for unauthenticated attackers to extract sensitive data from posts that have been restricted to higher-level roles such as logged-in users.

NVD CVE-2024-11153Wordfence advisoryCode change (fix)wordpress.org

medium 5.3 CVE-2024-0615 · published 2024-05-02

Information disclosure in Content Control (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.2.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Content Control – The Ultimate Content Restriction Plugin! Restrict Content, Create Conditional Blocks & More plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.1.0 via the API. This makes it possible for unauthenticated attackers to extract post titles, IDs, slugs, statuses and other information including post content. This includes published content only.

NVD CVE-2024-0615Wordfence advisoryCode change (fix)

medium 5.4 CVE-2022-4509 · published 2023-01-23

Stored cross-site scripting (XSS) in Content Control (older than 1.1.10)

Affected
older than 1.1.10
Fixed in
1.1.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Content Control WordPress plugin before 1.1.10 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks, which could be used against high privilege users such as admins.

NVD CVE-2022-4509WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Content Control vulnerability status badge
<a href="https://laskyr.com/plugins/content-control"><img src="https://laskyr.com/plugins/content-control/badge.svg" alt="Content Control vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit