Plugins · contact-manager · data as of 2026-11-04
Is Contact Manager safe? Known vulnerabilities and latest version
- Latest version
- 9.1.3
- Last updated
- 2026-10-27
- Active installs
- 100+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.3+
Allows you to create and manage your contact forms and messages. — by Kleor
What to do
- Update to the latest version (9.1.3). Anything older than 9.1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get contact-manager --field=version shows what you run; wp plugin update contact-manager updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.8 CVE-2026-109218 · published 2026-10-28
Arbitrary file upload in Contact Manager (9.1.2 and older)
- Affected
- 9.1.2 and older
- Fixed in
- 9.1.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Contact Manager plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 9.1.2 via the add_message function. This is due to an incomplete extension blacklist that fails to detect dangerous extensions when a trailing dot causes the extension-derivation routine to return an empty string, which sanitize_file_name() then silently removes before the file is written to disk. This makes it possible for unauthenticated attackers to upload files that may be executable, which makes remote code execution possible. Successful code execution additionally requires the server to use Apache with libapache2-mod-php (which maps .phar to PHP by default) and the attacker to retrieve the uploaded file within the brief window before it is removed by unlink() at end of request.
NVD CVE-2026-109218Wordfence advisoryCode change (fix)wordpress.orgPlugin source
high 7.1 CVE-2026-32517 · published 2026-03-25
Reflected cross-site scripting (XSS) in Contact Manager (9.1 and older)
- Affected
- 9.1 and older
- Fixed in
- 9.1.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kleor Contact Manager contact-manager allows Reflected XSS.This issue affects Contact Manager: from n/a through <= 9.1.
high 8.8 CVE-2025-68853 · published 2026-02-20
PHP object injection in Contact Manager (9.1.1 and older)
- Affected
- 9.1.1 and older
- Fixed in
- 9.1.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in Kleor Contact Manager contact-manager allows Object Injection.This issue affects Contact Manager: from n/a through <= 9.1.1.
medium 4.4 CVE-2025-8783 · published 2025-08-19
Stored cross-site scripting (XSS) in Contact Manager (8.6.5 and older)
- Affected
- 8.6.5 and older
- Fixed in
- 8.6.6 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Contact Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'title’ parameter in all versions up to, and including, 8.6.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
NVD CVE-2025-8783Wordfence advisoryCode change (fix)Plugin source
high 8.1 CVE-2025-1028 · published 2025-02-05
Arbitrary file upload in Contact Manager (8.6.4 and older)
- Affected
- 8.6.4 and older
- Fixed in
- 8.6.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Contact Manager plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the contact form upload feature in all versions up to, and including, 8.6.4. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible in specific configurations where the first extension is processed over the final. This vulnerability also requires successfully exploiting a race condition in order to exploit.
Recent activity
- 2026-10-27 — latest release on wordpress.org (9.1.3).
- 2026-10-28 — Arbitrary file upload disclosed (CVE-2026-109218), fixed in 9.1.3.
- 2026-03-25 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-32517), fixed in 9.1.1.
- 2026-02-20 — PHP object injection disclosed (CVE-2025-68853), fixed in 9.1.2.
Get an email when Contact Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Contact Manager (contact-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Arbitrary file upload (2) · Cross-site scripting (XSS) (2) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/contact-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/contact-manager"><img src="https://laskyr.com/plugins/contact-manager/badge.svg" alt="Contact Manager vulnerability status"></a>