Plugins · contact-forms-anti-spam · data as of 2026-11-04
Is Spam Protection safe? Known vulnerabilities and latest version
- Latest version
- 3.1.4
- Last updated
- 2026-10-28
- Active installs
- 30,000+
- Known issues on record
- 8
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Blocks spam the moment you activate it. No CAPTCHA, no setup, no API key. Multi-Layer. Just install and forget. — by yonifre
What to do
- Update to the latest version (3.1.4). Anything older than 2.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get contact-forms-anti-spam --field=version shows what you run; wp plugin update contact-forms-anti-spam updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-28003 · published 2026-08-13
Cross-site scripting (XSS) in Spam Protection (2.9.1 and older)
- Affected
- 2.9.1 and older
- Fixed in
- 2.9.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Maspik – Spam blacklist <= 2.9.1 versions.
medium 4.3 CVE-2025-9979 · published 2025-09-10
Missing authorization check in Spam Protection (2.5.6 and older)
- Affected
- 2.5.6 and older
- Fixed in
- 2.5.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Maspik plugin for WordPress is vulnerable to Missing Authorization in version 2.5.6 and prior. This is due to missing capability checks on the Maspik_spamlog_download_csv function. This makes it possible for authenticated attackers, with subscriber-level access and above, to export and download the spam log database containing blocked submission attempts, which may include misclassified but legitimate submissions with sensitive data.
NVD CVE-2025-9979Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source
medium 4.3 CVE-2025-9888 · published 2025-09-10
Cross-site request forgery (CSRF) in Spam Protection (2.5.6 and older)
- Affected
- 2.5.6 and older
- Fixed in
- 2.5.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Maspik – Ultimate Spam Protection plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.5.6. This is due to missing or incorrect nonce validation on the clear_log function. This makes it possible for unauthenticated attackers to clear all spam logs via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-9888Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source
medium 5.4 CVE-2024-53806 · published 2024-12-06
Missing authorization check in Spam Protection (2.2.7 and older)
- Affected
- 2.2.7 and older
- Fixed in
- 2.2.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in yonifre Maspik – Spam blacklist contact-forms-anti-spam allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Maspik – Spam blacklist: from n/a through <= 2.2.7.
medium 5.3 CVE-2023-48271 · published 2024-06-04
Authentication bypass in Spam Protection (0.10.3 and older)
- Affected
- 0.10.3 and older
- Fixed in
- 0.10.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Authentication Bypass by Spoofing vulnerability in yonifre Maspik – Spam blacklist allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Maspik – Spam blacklist: from n/a through 0.10.3.
medium 4.8 CVE-2024-25101 · published 2024-03-13
Stored cross-site scripting (XSS) in Spam Protection (0.10.6 and older)
- Affected
- 0.10.6 and older
- Fixed in
- 0.10.7
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in yonifre Maspik – Spam Blacklist allows Stored XSS.This issue affects Maspik – Spam Blacklist: from n/a through 0.10.6.
medium 6.1 CVE-2023-48272 · published 2023-11-30
Stored cross-site scripting (XSS) in Spam Protection (0.9.2 and older)
- Affected
- 0.9.2 and older
- Fixed in
- 0.9.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in yonifre Maspik – Spam Blacklist allows Stored XSS.This issue affects Maspik – Spam Blacklist: from n/a through 0.9.2.
high 8.8 CVE-2023-24008 · published 2023-05-26
Cross-site request forgery (CSRF) in Spam Protection (0.7.8 and older)
- Affected
- 0.7.8 and older
- Fixed in
- 0.7.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in yonifre Maspik – Spam Blacklist plugin <= 0.7.8 versions.
Recent activity
- 2026-10-28 — latest release on wordpress.org (3.1.4).
- 2026-08-13 — Cross-site scripting (XSS) disclosed (CVE-2026-28003), fixed in 2.9.2.
- 2025-09-10 — Missing authorization check disclosed (CVE-2025-9979), fixed in 2.5.7.
- 2025-09-10 — Cross-site request forgery (CSRF) disclosed (CVE-2025-9888), fixed in 2.5.7.
Get an email when Spam Protection has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Spam Protection (contact-forms-anti-spam) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (2) · Cross-site request forgery (CSRF) (2) · Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/contact-forms-anti-spam (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/contact-forms-anti-spam"><img src="https://laskyr.com/plugins/contact-forms-anti-spam/badge.svg" alt="Spam Protection vulnerability status"></a>