Plugins · contact-form-to-any-api · data as of 2026-11-04
Is Contact Form to Any API safe? Known vulnerabilities and latest version
- Latest version
- 3.0.7
- Last updated
- 2026-10-28
- Active installs
- 8,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Send Contact Form 7 submissions to any API, Webhook or CRM — quick setup, flexible payloads, endpoints and authentication. — by IT Path Solutions
What to do
- Update to the latest version (3.0.7). Anything older than 3.0.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get contact-form-to-any-api --field=version shows what you run; wp plugin update contact-form-to-any-api updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-18946 · published 2026-08-10
Information disclosure in Contact Form to Any API (older than 3.0.7)
- Affected
- older than 3.0.7
- Fixed in
- 3.0.7
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Contact Form to Any API WordPress plugin before 3.0.7 does not use a random filename when copying files uploaded through contact forms into a publicly accessible directory, allowing unauthenticated attackers to enumerate and download files submitted by other users.
medium 6.4 CVE-2026-15735 · published 2026-07-29
Stored cross-site scripting (XSS) in Contact Form to Any API (3.0.6 and older)
- Affected
- 3.0.6 and older
- Fixed in
- 3.0.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Contact Form to Any API plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'cf7anyapi_form_field' Post Meta in all versions up to, and including, 3.0.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-15735Wordfence advisoryCode change (fix)Plugin source
high 7.1 CVE-2026-39449 · published 2026-06-15
Cross-site scripting (XSS) in Contact Form to Any API (3.0.3 and older)
- Affected
- 3.0.3 and older
- Fixed in
- 3.0.4 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Contact Form to Any API <= 3.0.3 versions.
medium 4.3 CVE-2023-47871 · published 2024-12-09
Missing authorization check in Contact Form to Any API (1.1.6 and older)
- Affected
- 1.1.6 and older
- Fixed in
- 1.1.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in IT Path Solutions Contact Form to Any API allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Contact Form to Any API: from n/a through 1.1.6.
medium 6.1 CVE-2024-7617 · published 2024-09-25
Stored cross-site scripting (XSS) in Contact Form to Any API (1.2.4 and older)
- Affected
- 1.2.4 and older
- Fixed in
- 1.2.5 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Contact Form to Any API plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Contact Form 7 form fields in all versions up to, and including, 1.2.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-7617Wordfence advisoryCode change (fix)Plugin source
high 8.5 CVE-2024-30242 · published 2024-03-28
SQL injection in Contact Form to Any API (1.1.8 and older)
- Affected
- 1.1.8 and older
- Fixed in
- 1.1.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in IT Path Solutions Contact Form to Any API.This issue affects Contact Form to Any API: from n/a through 1.1.8.
high 7.2 CVE-2023-32741 · published 2023-11-04
SQL injection in Contact Form to Any API (1.1.2 and older)
- Affected
- 1.1.2 and older
- Fixed in
- 1.1.3
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in IT Path Solutions PVT LTD Contact Form to Any API allows SQL Injection.This issue affects Contact Form to Any API: from n/a through 1.1.2.
NVD CVE-2023-32741Patchstack advisorypacketstormsecurity.com
Recent activity
- 2026-10-28 — latest release on wordpress.org (3.0.7).
- 2026-08-10 — Information disclosure disclosed (CVE-2026-18946), fixed in 3.0.7.
- 2026-07-29 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15735), fixed in 3.0.7.
- 2026-06-15 — Cross-site scripting (XSS) disclosed (CVE-2026-39449), fixed in 3.0.4.
Get an email when Contact Form to Any API has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Contact Form to Any API (contact-form-to-any-api) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · SQL injection (2) · Sensitive data exposure (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/contact-form-to-any-api (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/contact-form-to-any-api"><img src="https://laskyr.com/plugins/contact-form-to-any-api/badge.svg" alt="Contact Form to Any API vulnerability status"></a>