Plugins · contact-form-plugin · data as of 2026-11-04
Is Contact Form by BestWebSoft safe? Known vulnerabilities and latest version
- Latest version
- 4.3.9
- Last updated
- 2026-05-16
- Active installs
- 30,000+
- Known issues on record
- 8
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
The most powerful and user-friendly WordPress contact form plugin. Create beautiful contact forms, widgets and pages using shortcodes. — by bestwebsoft
What to do
- Update to the latest version (4.3.9). Anything older than 4.3.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get contact-form-plugin --field=version shows what you run; wp plugin update contact-form-plugin updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-63056 · published 2025-12-09
Missing authorization check in Contact Form by BestWebSoft (4.3.6 and older)
- Affected
- 4.3.6 and older
- Fixed in
- 4.3.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in bestwebsoft Contact Form by BestWebSoft contact-form-plugin allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Contact Form by BestWebSoft: from n/a through <= 4.3.6.
medium 6.1 CVE-2024-2198 · published 2024-04-09
Reflected cross-site scripting (XSS) in Contact Form by BestWebSoft (4.2.8 and older)
- Affected
- 4.2.8 and older
- Fixed in
- 4.2.9 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Contact Form by BestWebSoft plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘cntctfrm_contact_address’ parameter in all versions up to, and including, 4.2.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
medium 6.1 CVE-2024-2200 · published 2024-04-09
Reflected cross-site scripting (XSS) in Contact Form by BestWebSoft (4.2.8 and older)
- Affected
- 4.2.8 and older
- Fixed in
- 4.2.9 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Contact Form by BestWebSoft plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘cntctfrm_contact_subject’ parameter in all versions up to, and including, 4.2.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
medium 6.1 CVE-2013-7481 · published 2019-08-22
Cross-site scripting (XSS) in Contact Form by BestWebSoft (older than 3.3.5)
- Affected
- older than 3.3.5
- Fixed in
- 3.3.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The contact-form-plugin plugin before 3.3.5 for WordPress has XSS.
medium 6.1 CVE-2017-18491 · published 2019-08-13
Cross-site scripting (XSS) in Contact Form by BestWebSoft (older than 4.0.6)
- Affected
- older than 4.0.6
- Fixed in
- 4.0.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The contact-form-plugin plugin before 4.0.6 for WordPress has multiple XSS issues.
medium 6.1 CVE-2016-10869 · published 2019-08-13
Cross-site scripting (XSS) in Contact Form by BestWebSoft (older than 4.0.2)
- Affected
- older than 4.0.2
- Fixed in
- 4.0.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The contact-form-plugin plugin before 4.0.2 for WordPress has XSS.
medium 6.1 CVE-2013-7475 · published 2019-08-13
Cross-site scripting (XSS) in Contact Form by BestWebSoft (older than 3.52)
- Affected
- older than 3.52
- Fixed in
- 3.52
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The contact-form-plugin plugin before 3.52 for WordPress has XSS.
medium 6.1 CVE-2015-9295 · published 2019-08-13
Cross-site scripting (XSS) in Contact Form by BestWebSoft (older than 3.96)
- Affected
- older than 3.96
- Fixed in
- 3.96
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The contact-form-plugin plugin before 3.96 for WordPress has XSS.
Recent activity
- 2026-05-16 — latest release on wordpress.org (4.3.9).
- 2025-12-09 — Missing authorization check disclosed (CVE-2025-63056), fixed in 4.3.7.
- 2024-04-09 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-2198), fixed in 4.2.9.
- 2024-04-09 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-2200), fixed in 4.2.9.
Get an email when Contact Form by BestWebSoft has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Contact Form by BestWebSoft (contact-form-plugin) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by bestwebsoft (5 tracked)
Types found in this plugin: Cross-site scripting (XSS) (7) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/contact-form-plugin (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/contact-form-plugin"><img src="https://laskyr.com/plugins/contact-form-plugin/badge.svg" alt="Contact Form by BestWebSoft vulnerability status"></a>