Skip to content
Laskyr

Plugins · contact-form-7-paypal-add-on · data as of 2026-11-04

Is Contact Form 7 safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.3)

As of 2026-11-04. 7 issues are on record for older versions; version 2.5.2 or newer fixes all of them that state a fix.

Latest version
2.5.3
Last updated
2026-10-07
Active installs
7,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.5+

Easily add PayPal and Stripe to Contact Form 7. Accept credit card payments with Stripe & PayPal on your site today. Offical PayPal & Stripe Partner. — by Scott Paterson

What to do

  1. Update to the latest version (2.5.3). Anything older than 2.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get contact-form-7-paypal-add-on --field=version shows what you run; wp plugin update contact-form-7-paypal-add-on updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-66660 · published 2026-08-13

Missing authorization check in Contact Form 7 (2.5.1 and older)

Affected
2.5.1 and older
Fixed in
2.5.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Contact Form 7 – PayPal & Stripe Add-on <= 2.5.1 versions.

NVD CVE-2026-66660Patchstack advisory

medium 5.3 CVE-2026-9189 · published 2026-05-29

Security issue in Contact Form 7 (2.4.9 and older)

Affected
2.4.9 and older
Fixed in
2.4.10 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Contact Form 7 – PayPal & Stripe Add-on plugin for WordPress is vulnerable to Payment Bypass via Insufficient Verification of Data Authenticity in all versions up to, and including, 2.4.9. Although `cf7pp_paypal_ipn_handler()` correctly validates IPN authenticity by posting back to PayPal with `cmd=_notify-validate`, it fails to compare the IPN payload's `mc_gross` (payment amount), `mc_currency`, or `receiver_email` fields against the corresponding stored order values before passing the attacker-controlled `invoice` field directly to `cf7pp_complete_payment()`, which marks the order completed after only an integer cast with no amount verification. This makes it possible for unauthenticated attackers to mark arbitrary high-value pending orders as fully paid by making a minimal real PayPal payment and crafting an IPN whose `invoice` parameter references the targeted order, effectively completing purchases without tendering the required payment amount.

NVD CVE-2026-9189Wordfence advisoryCode change (fix)Plugin source

medium 5.9 CVE-2025-47518 · published 2025-05-07

Stored cross-site scripting (XSS) in Contact Form 7 (2.3.4 and older)

Affected
2.3.4 and older
Fixed in
2.4.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Scott Paterson Contact Form 7 – PayPal & Stripe Add-on contact-form-7-paypal-add-on allows Stored XSS.This issue affects Contact Form 7 – PayPal & Stripe Add-on: from n/a through <= 2.3.4.

NVD CVE-2025-47518Patchstack advisory

medium 6.1 CVE-2024-10683 · published 2024-11-09

Reflected cross-site scripting (XSS) in Contact Form 7 (2.3.1 and older)

Affected
2.3.1 and older
Fixed in
2.3.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Contact Form 7 – PayPal & Stripe Add-on plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg & remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.3.1. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This is only exploitable when the leave a review notice is present in the dashboard.

NVD CVE-2024-10683Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2024-48021 · published 2024-10-17

Reflected cross-site scripting (XSS) in Contact Form 7 (2.3 and older)

Affected
2.3 and older
Fixed in
2.3.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Scott Paterson Contact Form 7 – PayPal & Stripe Add-on contact-form-7-paypal-add-on allows Reflected XSS.This issue affects Contact Form 7 – PayPal & Stripe Add-on: from n/a through <= 2.3.

NVD CVE-2024-48021Patchstack advisory

medium 6.1 CVE-2024-29130 · published 2024-03-19

Reflected cross-site scripting (XSS) in Contact Form 7 (2.0 and older)

Affected
2.0 and older
Fixed in
2.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Scott Paterson Contact Form 7 – PayPal & Stripe Add-on allows Reflected XSS.This issue affects Contact Form 7 – PayPal & Stripe Add-on: from n/a through 2.0.

NVD CVE-2024-29130Patchstack advisory

high 8.8 CVE-2023-24405 · published 2023-07-10

Cross-site request forgery (CSRF) in Contact Form 7 (1.9.3 and older)

Affected
1.9.3 and older
Fixed in
1.9.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Scott Paterson Contact Form 7 – PayPal & Stripe Add-on plugin <= 1.9.3 versions.

NVD CVE-2023-24405Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Contact Form 7 vulnerability status badge
<a href="https://laskyr.com/plugins/contact-form-7-paypal-add-on"><img src="https://laskyr.com/plugins/contact-form-7-paypal-add-on/badge.svg" alt="Contact Form 7 vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit