Skip to content
Laskyr

Plugins · contact-form-7-multi-step-module · data as of 2026-11-04

Is Webheadcoder Multi-Step Forms for Contact Form 7 safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.7.1)

As of 2026-11-04. 1 issue is on record for older versions; version 4.7.1 or newer fixes all of them that state a fix.

Latest version
4.7.1
Last updated
2026-10-09
Active installs
50,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.3+

Adds multi-page, multi-step forms to Contact Form 7. — by webheadcoder

What to do

  1. Update to the latest version (4.7.1). Anything older than 4.7.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get contact-form-7-multi-step-module --field=version shows what you run; wp plugin update contact-form-7-multi-step-module updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-92098 · published 2026-10-28

Reflected cross-site scripting (XSS) in Webheadcoder Multi-Step Forms for Contact Form 7 (4.7 and older)

Affected
4.7 and older
Fixed in
4.7.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Webheadcoder Multi-Step Forms for Contact Form 7 plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'l10n_print_after' parameter in all versions up to, and including, 4.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Successful exploitation requires that the targeted site has at least one Contact Form 7 form configured with a [multistep] form-tag, as the canonicalization introduced in version 4.7 blocks the attack path on non-multistep forms.

NVD CVE-2026-92098Wordfence advisorygithub.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Webheadcoder Multi-Step Forms for Contact Form 7 vulnerability status badge
<a href="https://laskyr.com/plugins/contact-form-7-multi-step-module"><img src="https://laskyr.com/plugins/contact-form-7-multi-step-module/badge.svg" alt="Webheadcoder Multi-Step Forms for Contact Form 7 vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit