Plugins · contact-form-7-mailchimp-extension · data as of 2026-11-04
Is Connect Contact Form 7 to Mailchimp, Brevo, Ma… safe? Known vulnerabilities and latest version
- Latest version
- 26.11.01.19
- Last updated
- 2026-11-01
- Active installs
- 40,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Grow your email list from Contact Form 7. Connect to eight email platforms and bring the subscriber details you choose. — by Renzo Johnson
What to do
- Update to the latest version (26.11.01.19). Anything older than 26.11.01.19 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get contact-form-7-mailchimp-extension --field=version shows what you run; wp plugin update contact-form-7-mailchimp-extension updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-15000 · published 2026-07-09
Stored cross-site scripting (XSS) in Connect Contact Form 7 to Mailchimp, Brevo, Ma… (0.9.78.06 and older)
- Affected
- 0.9.78.06 and older
- Fixed in
- 26.11.01.19 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Connect Contact Form 7 and Mailchimp plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Mailchimp Merge Field Values in all versions up to, and including, 0.9.78.06 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload is only triggered when a privileged user (Administrator) performs a Contact Lookup for the email address submitted via the CF7 form, meaning execution is deferred until an administrator interacts with the affected entry.
NVD CVE-2026-15000Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-68989 · published 2025-12-30
Information disclosure in Connect Contact Form 7 to Mailchimp, Brevo, Ma… (0.9.68 and older)
- Affected
- 0.9.68 and older
- Fixed in
- 0.9.69
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in Renzo Johnson contact-form-7-mailchimp-extension contact-form-7-mailchimp-extension allows Retrieve Embedded Sensitive Data.This issue affects contact-form-7-mailchimp-extension: from n/a through <= 0.9.68.
medium 4.3 CVE-2024-33677 · published 2024-04-26
Cross-site request forgery (CSRF) in Connect Contact Form 7 to Mailchimp, Brevo, Ma… (0.5.70 and older)
- Affected
- 0.5.70 and older
- Fixed in
- 26.11.01.19 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Renzo Johnson Contact Form 7 Extension For Mailchimp.This issue affects Contact Form 7 Extension For Mailchimp: from n/a through 0.5.70.
medium 6.5 CVE-2024-22134 · published 2024-01-24
Server-side request forgery (SSRF) in Connect Contact Form 7 to Mailchimp, Brevo, Ma… (0.5.70 and older)
- Affected
- 0.5.70 and older
- Fixed in
- 26.11.01.19 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in Renzo Johnson Contact Form 7 Extension For Mailchimp.This issue affects Contact Form 7 Extension For Mailchimp: from n/a through 0.5.70.
Recent activity
- 2026-11-01 — latest release on wordpress.org (26.11.01.19).
- 2026-07-09 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15000), fixed in 26.11.01.19.
- 2025-12-30 — Information disclosure disclosed (CVE-2025-68989), fixed in 0.9.69.
- 2024-04-26 — Cross-site request forgery (CSRF) disclosed (CVE-2024-33677), fixed in 26.11.01.19.
Get an email when Connect Contact Form 7 to Mailchimp, Brevo, Ma… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Connect Contact Form 7 to Mailchimp, Brevo, Ma… (contact-form-7-mailchimp-extension) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Renzo Johnson (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Sensitive data exposure (1) · Cross-site request forgery (CSRF) (1) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/contact-form-7-mailchimp-extension (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/contact-form-7-mailchimp-extension"><img src="https://laskyr.com/plugins/contact-form-7-mailchimp-extension/badge.svg" alt="Connect Contact Form 7 to Mailchimp, Brevo, Ma… vulnerability status"></a>