Skip to content
Laskyr

Plugins · conekta-payment-gateway · data as of 2026-11-04

Is Conekta Payment Gateway safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.2.5)

As of 2026-11-04. 3 issues are on record for older versions; version 6.2.5 or newer fixes all of them that state a fix.

Latest version
6.2.5
Last updated
2026-09-21
Active installs
2,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WooCommerce Payment Gateway for Conekta.io This bundles functionality to process credit and debit cards, monthly installments (MSI), cash, bank transf … — by Conekta Group

What to do

  1. Update to the latest version (6.2.5). Anything older than 6.2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get conekta-payment-gateway --field=version shows what you run; wp plugin update conekta-payment-gateway updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-95527 · published 2026-09-23

Missing authorization check in Conekta Payment Gateway (6.2.4 and older)

Affected
6.2.4 and older
Fixed in
6.2.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in Conekta Payment Gateway <= 6.2.4 versions.

NVD CVE-2026-95527Patchstack advisory

medium 5.3 CVE-2026-16738 · published 2026-08-22

Missing authorization check in Conekta Payment Gateway (older than 6.2.2)

Affected
older than 6.2.2
Fixed in
6.2.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Conekta Payment Gateway WordPress plugin before 6.2.2 does not verify the authenticity of incoming payment gateway webhook notifications, nor bind the confirmed payment to the targeted order or verify its amount, allowing unauthenticated attackers to mark arbitrary orders as paid without payment.

NVD CVE-2026-16738WPScan advisory

high 7.5 CVE-2026-49066 · published 2026-06-15

Information disclosure in Conekta Payment Gateway (6.0.0 and older)

Affected
6.0.0 and older
Fixed in
6.0.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Sensitive Data Exposure in Conekta Payment Gateway <= 6.0.0 versions.

NVD CVE-2026-49066Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Conekta Payment Gateway vulnerability status badge
<a href="https://laskyr.com/plugins/conekta-payment-gateway"><img src="https://laskyr.com/plugins/conekta-payment-gateway/badge.svg" alt="Conekta Payment Gateway vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit