Skip to content
Laskyr

Plugins · conditional-menus · data as of 2026-11-04

Is Conditional Menus safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.9)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.7 or newer fixes all of them that state a fix.

Latest version
1.2.9
Last updated
2026-08-12
Active installs
60,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8

This plugin enables you to set conditional menus per posts, pages, categories, archive pages, etc. — by themifyme

What to do

  1. Update to the latest version (1.2.9). Anything older than 1.2.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get conditional-menus --field=version shows what you run; wp plugin update conditional-menus updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-1032 · published 2026-03-26

Cross-site request forgery (CSRF) in Conditional Menus (1.2.6 and older)

Affected
1.2.6 and older
Fixed in
1.2.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Conditional Menus plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.2.6. This is due to missing nonce validation on the 'save_options' function. This makes it possible for unauthenticated attackers to modify conditional menu assignments via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2026-1032Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2023-2654 · published 2023-06-19

Reflected cross-site scripting (XSS) in Conditional Menus (older than 1.2.1)

Affected
older than 1.2.1
Fixed in
1.2.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Conditional Menus WordPress plugin before 1.2.1 does not escape a parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

NVD CVE-2023-2654WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Conditional Menus vulnerability status badge
<a href="https://laskyr.com/plugins/conditional-menus"><img src="https://laskyr.com/plugins/conditional-menus/badge.svg" alt="Conditional Menus vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit