Skip to content
Laskyr

Plugins · collectchat · data as of 2026-11-04

Is Chatbot for WordPress by Collect.chat ⚡️ safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.1)

As of 2026-11-04. 5 issues are on record for older versions; version 2.5.0 or newer fixes all of them that state a fix.

Latest version
2.5.1
Last updated
2026-05-17
Active installs
6,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8

Chatbots without AI are the easiest way to collect leads & data from visitors. Create a free chatbot without coding using Collect.chat. — by collectchat

What to do

  1. Update to the latest version (2.5.1). Anything older than 2.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get collectchat --field=version shows what you run; wp plugin update collectchat updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-40765 · published 2026-06-17

Cross-site scripting (XSS) in Chatbot for WordPress by Collect.chat ⚡️ (2.4.9 and older)

Affected
2.4.9 and older
Fixed in
2.5.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in collectchat <= 2.4.9 versions.

NVD CVE-2026-40765Patchstack advisory

medium 6.4 CVE-2026-0736 · published 2026-02-14

Stored cross-site scripting (XSS) in Chatbot for WordPress by Collect.chat ⚡️ (2.4.8 and older)

Affected
2.4.8 and older
Fixed in
2.4.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Chatbot for WordPress by Collect.chat plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the '_inpost_head_script[synth_header_script]' post meta field in all versions up to, and including, 2.4.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-0736Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2024-6498 · published 2024-08-05

Cross-site scripting (XSS) in Chatbot for WordPress by Collect.chat ⚡️ (older than 2.4.4)

Affected
older than 2.4.4
Fixed in
2.4.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Chatbot for WordPress by Collect.chat ⚡️ WordPress plugin before 2.4.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed

NVD CVE-2024-6498WPScan advisory

medium 6.5 CVE-2024-30436 · published 2024-03-29

Stored cross-site scripting (XSS) in Chatbot for WordPress by Collect.chat ⚡️ (2.4.1 and older)

Affected
2.4.1 and older
Fixed in
2.4.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Collect.Chat Inc. Collectchat allows Stored XSS.This issue affects Collectchat: from n/a through 2.4.1.

NVD CVE-2024-30436Patchstack advisory

medium 4.8 CVE-2023-5691 · published 2024-01-11

Stored cross-site scripting (XSS) in Chatbot for WordPress by Collect.chat ⚡️ (2.3.9 only)

Affected
2.3.9 only
Fixed in
2.4.0 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Chatbot for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in version 2.3.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2023-5691Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Chatbot for WordPress by Collect.chat ⚡️ vulnerability status badge
<a href="https://laskyr.com/plugins/collectchat"><img src="https://laskyr.com/plugins/collectchat/badge.svg" alt="Chatbot for WordPress by Collect.chat ⚡️ vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit