Skip to content
Laskyr

Plugins · collapsing-categories · data as of 2026-11-04

Is Collapsing Categories safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.12)

As of 2026-11-04. 2 issues are on record for older versions; version 3.0.12 or newer fixes all of them that state a fix.

Latest version
3.0.12
Last updated
2026-02-12
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Adds a widget which uses Javascript to dynamically expand or collapse the set of posts for each category. — by robfelty

What to do

  1. Update to the latest version (3.0.12). Anything older than 3.0.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get collapsing-categories --field=version shows what you run; wp plugin update collapsing-categories updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.5 CVE-2026-32366 · published 2026-03-13

SQL injection in Collapsing Categories (3.0.9 and older)

Affected
3.0.9 and older
Fixed in
3.0.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in robfelty Collapsing Categories collapsing-categories allows Blind SQL Injection.This issue affects Collapsing Categories: from n/a through <= 3.0.9.

NVD CVE-2026-32366Patchstack advisory

high 7.5 CVE-2024-12025 · published 2024-12-18

SQL injection in Collapsing Categories (3.0.8 and older)

Affected
3.0.8 and older
Fixed in
3.0.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Collapsing Categories plugin for WordPress is vulnerable to SQL Injection via the 'taxonomy' parameter of the /wp-json/collapsing-categories/v1/get REST API in all versions up to, and including, 3.0.8 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2024-12025Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Collapsing Categories vulnerability status badge
<a href="https://laskyr.com/plugins/collapsing-categories"><img src="https://laskyr.com/plugins/collapsing-categories/badge.svg" alt="Collapsing Categories vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit