Skip to content
Laskyr

Plugins · collapsing-archives · data as of 2026-11-04

Is Collapsing Archives safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.8)

As of 2026-11-04. 2 issues are on record for older versions; version 3.0.8 or newer fixes all of them that state a fix.

Latest version
3.0.8
Last updated
2026-02-12
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

This plugin uses Javascript to dynamically expand or collapse the set of months for each year and posts for each month in the archive listing of your … — by robfelty

What to do

  1. Update to the latest version (3.0.8). Anything older than 3.0.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get collapsing-archives --field=version shows what you run; wp plugin update collapsing-archives updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.5 CVE-2026-32365 · published 2026-03-13

SQL injection in Collapsing Archives (3.0.7 and older)

Affected
3.0.7 and older
Fixed in
3.0.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in robfelty Collapsing Archives collapsing-archives allows Blind SQL Injection.This issue affects Collapsing Archives: from n/a through <= 3.0.7.

NVD CVE-2026-32365Patchstack advisory

medium 5.4 CVE-2024-43934 · published 2024-08-29

Stored cross-site scripting (XSS) in Collapsing Archives (3.0.5 and older)

Affected
3.0.5 and older
Fixed in
3.0.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Robert Felty Collapsing Archives allows Stored XSS.This issue affects Collapsing Archives: from n/a through 3.0.5.

NVD CVE-2024-43934Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Collapsing Archives vulnerability status badge
<a href="https://laskyr.com/plugins/collapsing-archives"><img src="https://laskyr.com/plugins/collapsing-archives/badge.svg" alt="Collapsing Archives vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit