Plugins · codepress-admin-columns · data as of 2026-11-04
Is Admin Columns safe? Known vulnerabilities and latest version
- Latest version
- 7.1.8
- Last updated
- 2026-10-27
- Active installs
- 100,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Take control of your WordPress admin list tables. Add, remove, and reorder columns for posts, users, media, and more - no coding needed. — by Codepress
What to do
- Update to the latest version (7.1.8). Anything older than 7.0.19 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get codepress-admin-columns --field=version shows what you run; wp plugin update codepress-admin-columns updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-7654 · published 2026-06-05
PHP object injection in Admin Columns (7.0.18 and older)
- Affected
- 7.0.18 and older
- Fixed in
- 7.0.19 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Admin Columns plugin for WordPress is vulnerable to PHP Object Injection leading to Remote Code Execution in versions up to and including 7.0.18. This is due to the use of `unserialize()` without an `allowed_classes` restriction in the `IdsToCollection::get_ids_from_string()` function, which processes attacker-controlled post meta values without proper validation. This makes it possible for authenticated attackers with Contributor-level access and above to inject a serialized PHP object into a post's custom meta field and trigger arbitrary code execution by exploiting a bundled POP gadget chain, resulting in remote code execution as the web server user.
NVD CVE-2026-7654Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2021-24365 · published 2021-07-12
Cross-site scripting (XSS) in Admin Columns (older than 4.3.2)
- Affected
- older than 4.3.2
- Fixed in
- 4.3.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Admin Columns WordPress plugin Free before 4.3.2 and Pro before 5.5.2 allowed to configure individual columns for tables. Each column had a type. The type "Custom Field" allowed to choose an arbitrary database column to display in the table. There was no escaping applied to the contents of "Custom Field" columns.
medium 5.4 CVE-2021-24366 · published 2021-06-21
Stored cross-site scripting (XSS) in Admin Columns (3.0 up to (not including) 4.3)
- Affected
- 3.0 up to (not including) 4.3
- Fixed in
- 4.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Admin Columns WordPress plugin before 4.3 and Admin Columns Pro WordPress plugin before 5.5.1 do not sanitise and escape its Label settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
NVD CVE-2021-24366WPScan advisorygithub.comwhitesourcesoftware.com
Recent activity
- 2026-10-27 — latest release on wordpress.org (7.1.8).
- 2026-06-05 — PHP object injection disclosed (CVE-2026-7654), fixed in 7.0.19.
- 2021-07-12 — Cross-site scripting (XSS) disclosed (CVE-2021-24365), fixed in 4.3.2.
- 2021-06-21 — Stored cross-site scripting (XSS) disclosed (CVE-2021-24366), fixed in 4.3.
Get an email when Admin Columns has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Admin Columns (codepress-admin-columns) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/codepress-admin-columns (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/codepress-admin-columns"><img src="https://laskyr.com/plugins/codepress-admin-columns/badge.svg" alt="Admin Columns vulnerability status"></a>