Skip to content
Laskyr

Plugins · codepeople-post-map · data as of 2026-11-04

Is CodePeople Post Map for Google Maps safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.0)

As of 2026-11-04. 3 issues are on record for older versions; version 1.2.7 or newer fixes all of them that state a fix.

Latest version
1.3.0
Last updated
2026-08-15
Active installs
3,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

CodePeople Post Map lets you geotag posts and seamlessly integrate your blog with Google Maps for a smooth, location-aware experience. — by codepeople

What to do

  1. Update to the latest version (1.3.0). Anything older than 1.2.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get codepeople-post-map --field=version shows what you run; wp plugin update codepeople-post-map updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-57670 · published 2026-07-02

Cross-site scripting (XSS) in CodePeople Post Map for Google Maps (1.2.5 and older)

Affected
1.2.5 and older
Fixed in
1.2.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Google Maps CP <= 1.2.5 versions.

NVD CVE-2026-57670Patchstack advisory

medium 6.4 CVE-2026-13335 · published 2026-06-27

Stored cross-site scripting (XSS) in CodePeople Post Map for Google Maps (1.2.6 and older)

Affected
1.2.6 and older
Fixed in
1.2.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CodePeople Post Map for Google Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'cpm_point' Post Meta in all versions up to, and including, 1.2.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-13335Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2023-25039 · published 2024-03-25

Missing authorization check in CodePeople Post Map for Google Maps (1.0.43 and older)

Affected
1.0.43 and older
Fixed in
1.0.44
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in CodePeople Google Maps CP.This issue affects Google Maps CP: from n/a through 1.0.43.

NVD CVE-2023-25039Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CodePeople Post Map for Google Maps vulnerability status badge
<a href="https://laskyr.com/plugins/codepeople-post-map"><img src="https://laskyr.com/plugins/codepeople-post-map/badge.svg" alt="CodePeople Post Map for Google Maps vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit