Plugins · codecolorer · data as of 2026-11-04
Is CodeColorer safe? Known vulnerabilities and latest version
- Latest version
- 0.12.0
- Last updated
- 2026-08-15
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Syntax highlighting for code snippets in posts, comments, and RSS, with inline code, themes, and line numbers. — by Dmytro Shteflyuk
What to do
- Update to the latest version (0.12.0). Anything older than 0.10.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get codecolorer --field=version shows what you run; wp plugin update codecolorer updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-4032 · published 2026-04-16
Stored cross-site scripting (XSS) in CodeColorer (0.10.1 and older)
- Affected
- 0.10.1 and older
- Fixed in
- 0.10.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CodeColorer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'class' parameter in 'cc' comment shortcode in versions up to, and including, 0.10.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires comments to be enabled on the target post and guest comments to be allowed.
high 7.1 CVE-2025-68012 · published 2026-01-22
Stored cross-site scripting (XSS) in CodeColorer (0.10.1 and older)
- Affected
- 0.10.1 and older
- Fixed in
- 0.10.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Dmytro Shteflyuk CodeColorer codecolorer allows Stored XSS.This issue affects CodeColorer: from n/a through <= 0.10.1.
medium 4.8 CVE-2023-2795 · published 2023-06-27
Stored cross-site scripting (XSS) in CodeColorer (older than 0.10.1)
- Affected
- older than 0.10.1
- Fixed in
- 0.10.1
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The CodeColorer WordPress plugin before 0.10.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Recent activity
- 2026-08-15 — latest release on wordpress.org (0.12.0).
- 2026-04-16 — Stored cross-site scripting (XSS) disclosed (CVE-2026-4032), fixed in 0.10.2.
- 2026-01-22 — Stored cross-site scripting (XSS) disclosed (CVE-2025-68012), fixed in 0.10.2.
- 2023-06-27 — Stored cross-site scripting (XSS) disclosed (CVE-2023-2795), fixed in 0.10.1.
Get an email when CodeColorer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for CodeColorer (codecolorer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/codecolorer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/codecolorer"><img src="https://laskyr.com/plugins/codecolorer/badge.svg" alt="CodeColorer vulnerability status"></a>