Skip to content
Laskyr

Plugins · coblocks · data as of 2026-11-01

Is Page Builder Gutenberg Blocks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.17)

As of 2026-11-01. 7 issues are on record for older versions; version 3.1.17 or newer fixes all of them that state a fix.

Latest version
3.1.17
Last updated
2026-03-05
Active installs
300,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 7.4+

CoBlocks is a suite of page builder WordPress blocks for Gutenberg, with 10+ new blocks and a true page builder experience with rows and columns. — by GoDaddy

What to do

  1. Update to the latest version (3.1.17). Anything older than 3.1.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get coblocks --field=version shows what you run; wp plugin update coblocks updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-4801 · published 2026-04-18

Stored cross-site scripting (XSS) in Page Builder Gutenberg Blocks (3.1.16 and older)

Affected
3.1.16 and older
Fixed in
3.1.17 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Page Builder Gutenberg Blocks – CoBlocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via external iCal feed data in all versions up to, and including, 3.1.16 due to insufficient output escaping of event titles, descriptions, and locations fetched from external iCal feeds in the Events block rendering function. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-4801Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-27094 · published 2026-02-19

Stored cross-site scripting (XSS) in Page Builder Gutenberg Blocks (3.1.16 and older)

Affected
3.1.16 and older
Fixed in
3.1.17
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GoDaddy CoBlocks coblocks allows Stored XSS.This issue affects CoBlocks: from n/a through <= 3.1.16.

NVD CVE-2026-27094Patchstack advisory

medium 4.3 CVE-2025-24751 · published 2025-01-24

Missing authorization check in Page Builder Gutenberg Blocks (3.1.13 and older)

Affected
3.1.13 and older
Fixed in
3.1.14
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in GoDaddy CoBlocks coblocks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CoBlocks: from n/a through <= 3.1.13.

NVD CVE-2025-24751Patchstack advisory

medium 4.8 CVE-2024-7132 · published 2024-08-29

Stored cross-site scripting (XSS) in Page Builder Gutenberg Blocks (older than 3.1.13)

Affected
older than 3.1.13
Fixed in
3.1.13
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Page Builder Gutenberg Blocks WordPress plugin before 3.1.13 does not escape the content of post embed via one of its block, which could allow users with the capability to publish posts (editor and admin by default) to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

NVD CVE-2024-7132WPScan advisory

medium 6.5 CVE-2024-4260 · published 2024-07-23

Server-side request forgery (SSRF) in Page Builder Gutenberg Blocks (older than 3.1.12)

Affected
older than 3.1.12
Fixed in
3.1.12
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Page Builder Gutenberg Blocks WordPress plugin before 3.1.12 does not prevent users from pinging arbitrary hosts via some of its shortcodes, which could allow high privilege users such as contributors to perform SSRF attacks.

NVD CVE-2024-4260WPScan advisory

medium 6.4 CVE-2024-2933 · published 2024-06-01

Stored cross-site scripting (XSS) in Page Builder Gutenberg Blocks (3.1.9 and older)

Affected
3.1.9 and older
Fixed in
3.1.10 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Page Builder Gutenberg Blocks – CoBlocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Social Profiles widget in all versions up to, and including, 3.1.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2933Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-2369 · published 2024-04-02

Stored cross-site scripting (XSS) in Page Builder Gutenberg Blocks (older than 3.1.7)

Affected
older than 3.1.7
Fixed in
3.1.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Page Builder Gutenberg Blocks WordPress plugin before 3.1.7 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

NVD CVE-2024-2369WPScan advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Page Builder Gutenberg Blocks vulnerability status badge
<a href="https://laskyr.com/plugins/coblocks"><img src="https://laskyr.com/plugins/coblocks/badge.svg" alt="Page Builder Gutenberg Blocks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit