Plugins · co-marquage-service-public · data as of 2026-11-04
Is Co-marquage service-public.fr safe? Known vulnerabilities and latest version
- Latest version
- 0.5.77
- Last updated
- 2024-11-20
- Active installs
- 1,000+
- Known issues on record
- 4
- Unpatched in latest
- 1
- Tested up to WP
- 6.7.11
Link to the French government service (co-marquage): service-public.fr — by emendo_seb
What to do
- There is no fixed version yet. If you can live without Co-marquage service-public.fr for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get co-marquage-service-public --field=version shows what you run; wp plugin update co-marquage-service-public updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 affects latest 0.5.77 CVE-2025-62113 · published 2025-12-31
Cross-site request forgery (CSRF) in Co-marquage service-public.fr (0.5.77 and older)
- Affected
- 0.5.77 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in emendo_seb Co-marquage service-public.fr co-marquage-service-public allows Cross Site Request Forgery.This issue affects Co-marquage service-public.fr: from n/a through <= 0.5.77.
medium 6.1 CVE-2024-10522 · published 2024-11-21
Reflected cross-site scripting (XSS) in Co-marquage service-public.fr (0.5.76 and older)
- Affected
- 0.5.76 and older
- Fixed in
- 0.5.77 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Co-marquage service-public.fr plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 0.5.76. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-10522Wordfence advisoryCode change (fix)wordpress.orgPlugin source
high 7.1 CVE-2024-29758 · published 2024-03-27
Reflected cross-site scripting (XSS) in Co-marquage service-public.fr (0.5.72 and older)
- Affected
- 0.5.72 and older
- Fixed in
- 0.5.73
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kienso Co-marquage service-public.Fr allows Reflected XSS.This issue affects Co-marquage service-public.Fr: from n/a through 0.5.72.
medium 6.5 CVE-2024-29908 · published 2024-03-27
Stored cross-site scripting (XSS) in Co-marquage service-public.fr (0.5.71 and older)
- Affected
- 0.5.71 and older
- Fixed in
- 0.5.72
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kienso Co-marquage service-public.Fr allows Stored XSS.This issue affects Co-marquage service-public.Fr: from n/a through 0.5.71.
Recent activity
- 2024-11-20 — latest release on wordpress.org (0.5.77).
- 2025-12-31 — Cross-site request forgery (CSRF) disclosed (CVE-2025-62113), no fix listed yet.
- 2024-11-21 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-10522), fixed in 0.5.77.
- 2024-03-27 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-29758), fixed in 0.5.73.
Get an email when Co-marquage service-public.fr has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Co-marquage service-public.fr (co-marquage-service-public) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/co-marquage-service-public (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/co-marquage-service-public"><img src="https://laskyr.com/plugins/co-marquage-service-public/badge.svg" alt="Co-marquage service-public.fr vulnerability status"></a>