Skip to content
Laskyr

Plugins · cmp-coming-soon-maintenance · data as of 2026-11-04

Is CMP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.1.22)

As of 2026-11-04. 8 issues are on record for older versions; version 4.1.18 or newer fixes all of them that state a fix.

Latest version
4.1.22
Last updated
2026-10-16
Active installs
200,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Beautiful Coming soon, Maintenance or Landing page on your website, packed with premium features for free. — by NiteoThemes

What to do

  1. Update to the latest version (4.1.22). Anything older than 4.1.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cmp-coming-soon-maintenance --field=version shows what you run; wp plugin update cmp-coming-soon-maintenance updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-12470 · published 2026-09-22

Privilege escalation in CMP (4.1.17 and older)

Affected
4.1.17 and older
Fixed in
4.1.18 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CMP – Coming Soon & Maintenance Plugin by NiteoThemes plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the 'cmp_ajax_import_settings' AJAX action in all versions up to, and including, 4.1.17. This makes it possible for authenticated attackers, with Editor-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.

NVD CVE-2026-12470Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2026-6518 · published 2026-04-18

Arbitrary file upload in CMP (4.1.16 and older)

Affected
4.1.16 and older
Fixed in
4.1.17 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CMP – Coming Soon & Maintenance Plugin by NiteoThemes plugin for WordPress is vulnerable to arbitrary file upload and remote code execution in all versions up to, and including, 4.1.16 via the `cmp_theme_update_install` AJAX action. This is due to the function only checking for the `publish_pages` capability (available to Editors and above) instead of `manage_options` (Administrators only), combined with a lack of proper validation on the user-supplied file URL and no verification of the downloaded file's content before extraction. This makes it possible for authenticated attackers, with Administrator-level access and above, to force the server to download and extract a malicious ZIP file from a remote attacker-controlled URL into a web-accessible directory (`wp-content/plugins/cmp-premium-themes/`), resulting in remote code execution. Due to the lack of a nonce for Editors, they are unable to exploit this vulnerability.

NVD CVE-2026-6518Wordfence advisoryCode change (fix)Plugin source

critical 9.1 CVE-2025-32118 · published 2025-04-04

Arbitrary file upload in CMP (4.1.14 and older)

Affected
4.1.14 and older
Fixed in
4.1.15
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in NiteoThemes CMP – Coming Soon & Maintenance cmp-coming-soon-maintenance allows Using Malicious Files.This issue affects CMP – Coming Soon & Maintenance: from n/a through <= 4.1.14.

NVD CVE-2025-32118Patchstack advisory

medium 5.5 CVE-2023-50374 · published 2024-03-28

Server-side request forgery (SSRF) in CMP (4.1.10 and older)

Affected
4.1.10 and older
Fixed in
4.1.11
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in NiteoThemes CMP – Coming Soon & Maintenance.This issue affects CMP – Coming Soon & Maintenance: from n/a through 4.1.10.

NVD CVE-2023-50374Patchstack advisory

medium 5.3 CVE-2023-2159 · published 2023-06-09

Missing authorization check in CMP (4.1.7 and older)

Affected
4.1.7 and older
Fixed in
4.1.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The CMP – Coming Soon & Maintenance plugin for WordPress is vulnerable to Maintenance Mode Bypass in versions up to, and including, 4.1.7. A correct cmp_bypass GET parameter in the URL (equal to the md5-hashed home_url in the default setting) allows users to visit a site placed in maintenance mode thus bypassing the plugin's provided feature.

NVD CVE-2023-2159Wordfence advisoryCode change (fix)Plugin source

critical 9.3 CVE-2020-36730 · published 2023-06-07

Missing authorization check in CMP (3.8.1 and older)

Affected
3.8.1 and older
Fixed in
3.8.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The CMP for WordPress is vulnerable to authorization bypass due to a missing capability check on the cmp_get_post_detail(), niteo_export_csv(), and cmp_disable_comingsoon_ajax() functions in versions up to, and including, 3.8.1. This makes it possible for unauthenticated attackers to read posts, export subscriber lists, and/or deactivate the plugin.

NVD CVE-2020-36730Wordfence advisoryWPScan advisoryblog.nintechnet.comacunetix.com

medium 5.3 CVE-2023-1263 · published 2023-03-07

Information disclosure in CMP (4.1.6 and older)

Affected
4.1.6 and older
Fixed in
4.1.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The CMP – Coming Soon & Maintenance plugin for WordPress is vulnerable to Information Exposure in versions up to, and including, 4.1.6 via the cmp_get_post_detail function. This can allow unauthenticated individuals to obtain the contents of any non-password-protected, published post or page even when maintenance mode is enabled.

NVD CVE-2023-1263Wordfence advisoryPlugin source

medium 5.3 CVE-2022-0188 · published 2022-02-14

Authentication bypass in CMP (older than 4.0.19)

Affected
older than 4.0.19
Fixed in
4.0.19
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The CMP WordPress plugin before 4.0.19 allows any user, even not logged in, to arbitrarily change the coming soon page layout.

NVD CVE-2022-0188WPScan advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CMP vulnerability status badge
<a href="https://laskyr.com/plugins/cmp-coming-soon-maintenance"><img src="https://laskyr.com/plugins/cmp-coming-soon-maintenance/badge.svg" alt="CMP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit