Plugins · cmb2 · data as of 2026-11-01
Is CMB2 safe? Known vulnerabilities and latest version
- Latest version
- 2.13.5
- Last updated
- 2026-10-27
- Active installs
- 300,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
CMB2 is a metabox, custom fields, and forms library for WordPress that will blow your mind. — by Justin Sternberg
What to do
- Update to the latest version (2.13.5). Anything older than 2.13.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get cmb2 --field=version shows what you run; wp plugin update cmb2 updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-116761 · published 2026-10-28
Stored cross-site scripting (XSS) in CMB2 (2.13.4 and older)
- Affected
- 2.13.4 and older
- Fixed in
- 2.13.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'cmb43ex1_grp[0][txt] (wysiwyg field inside group — field id controlled by integrator config)' parameter in all versions up to, and including, 2.13.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when a site integrator renders the plugin's documented front-end form helper with a wysiwyg field inside a repeatable group on a publicly accessible page.
NVD CVE-2026-116761Wordfence advisoryCode change (fix)github.comPlugin source
high 7.2 CVE-2026-97336 · published 2026-10-02
Stored cross-site scripting (XSS) in CMB2 (2.13.0 and older)
- Affected
- 2.13.0 and older
- Fixed in
- 2.13.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'file_list' Field Type in all versions up to, and including, 2.13.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when an integrating plugin or theme registers a file_list field on a publicly accessible front-end form or a user meta box, as CMB2 is a developer library and does not expose these fields by default.
NVD CVE-2026-97336Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2026-102772 · published 2026-10-02
Stored cross-site scripting (XSS) in CMB2 (2.13.1 and older)
- Affected
- 2.13.1 and older
- Fixed in
- 2.13.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the '<textarea_code field id> (e.g. kl_code, kl_post_code)' parameter in all versions up to, and including, 2.13.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The front-end save path requires only a CMB2 box nonce, which is emitted to all visitors including unauthenticated guests via a simple GET request, making the attack trivially reachable without any credentials on sites that expose a public CMB2 form writing a textarea_code field.
NVD CVE-2026-102772Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-97270 · published 2026-09-30
Cross-site scripting (XSS) in CMB2 (2.13.0 and older)
- Affected
- 2.13.0 and older
- Fixed in
- 2.13.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Cross Site Scripting (XSS) in CMB2 <= 2.13.0 versions.
medium 6.8 CVE-2026-80338 · published 2026-09-24
Privilege escalation in CMB2 (older than 2.13.0)
- Affected
- older than 2.13.0
- Fixed in
- 2.13.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The CMB2 WordPress plugin before 2.13.0 does not perform any capability check on one of its AJAX actions, allowing users with a role as low as Subscriber to create arbitrary WordPress options and corrupt existing ones, which can break core site settings and take the site offline. Exploitation requires the site's or another CMB2 WordPress plugin before 2.13.0 to have declared an oEmbed field, as the CMB2 WordPress plugin before 2.13.0 registers none of its own. The stored value is never attacker-controlled, so the issue does not lead to privilege escalation.
high 7.5 CVE-2024-1792 · published 2024-04-09
PHP object injection in CMB2 (2.10.1 and older)
- Affected
- 2.10.1 and older
- Fixed in
- 2.12.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The CMB2 plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.10.1 via deserialization of untrusted input from the text_datetime_timestamp_timezone field. This makes it possible for authenticated attackers, with contributor access or higher, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code. Please note that the plugin is a developer toolkit. For the vulnerability to become exploitable, the presence of a metabox activation in your code (via functions.php for example) is required.
Recent activity
- 2026-10-27 — latest release on wordpress.org (2.13.5).
- 2026-10-28 — Stored cross-site scripting (XSS) disclosed (CVE-2026-116761), fixed in 2.13.5.
- 2026-10-02 — Stored cross-site scripting (XSS) disclosed (CVE-2026-97336), fixed in 2.13.1.
- 2026-10-02 — Stored cross-site scripting (XSS) disclosed (CVE-2026-102772), fixed in 2.13.2.
Get an email when CMB2 has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for CMB2 (cmb2) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/cmb2 (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/cmb2"><img src="https://laskyr.com/plugins/cmb2/badge.svg" alt="CMB2 vulnerability status"></a>