Skip to content
Laskyr

Plugins · cm-on-demand-search-and-replace · data as of 2026-11-04

Is CM Search And Replace safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.7)

As of 2026-11-04. 5 issues are on record for older versions; version 1.5.6 or newer fixes all of them that state a fix.

Latest version
1.5.7
Last updated
2026-10-13
Active installs
2,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.2.4+

Search and replace words, phrases, and HTML within your website posts and pages. — by CreativeMindsSolutions

What to do

  1. Update to the latest version (1.5.7). Anything older than 1.5.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get cm-on-demand-search-and-replace --field=version shows what you run; wp plugin update cm-on-demand-search-and-replace updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-54045 · published 2025-12-16

Missing authorization check in CM Search And Replace (1.5.5 and older)

Affected
1.5.5 and older
Fixed in
1.5.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in CreativeMindsSolutions CM On Demand Search And Replace cm-on-demand-search-and-replace allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CM On Demand Search And Replace: from n/a through <= 1.5.5.

NVD CVE-2025-54045Patchstack advisory

medium 5.9 CVE-2025-54727 · published 2025-08-14

Stored cross-site scripting (XSS) in CM Search And Replace (1.5.2 and older)

Affected
1.5.2 and older
Fixed in
1.5.3
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CreativeMindsSolutions CM On Demand Search And Replace cm-on-demand-search-and-replace allows Stored XSS.This issue affects CM On Demand Search And Replace: from n/a through <= 1.5.2.

NVD CVE-2025-54727Patchstack advisory

medium 4.3 CVE-2025-54728 · published 2025-08-14

Cross-site request forgery (CSRF) in CM Search And Replace (1.5.2 and older)

Affected
1.5.2 and older
Fixed in
1.5.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in CreativeMindsSolutions CM On Demand Search And Replace cm-on-demand-search-and-replace allows Cross Site Request Forgery.This issue affects CM On Demand Search And Replace: from n/a through <= 1.5.2.

NVD CVE-2025-54728Patchstack advisory

high 8.8 CVE-2023-28749 · published 2023-11-22

Cross-site request forgery (CSRF) in CM Search And Replace (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in CreativeMindsSolutions CM On Demand Search And Replace plugin <= 1.3.0 versions.

NVD CVE-2023-28749Patchstack advisory

medium 4.8 CVE-2023-31228 · published 2023-08-18

Stored cross-site scripting (XSS) in CM Search And Replace (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in CreativeMindsSolutions CM On Demand Search And Replace plugin <= 1.3.0 versions.

NVD CVE-2023-31228Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CM Search And Replace vulnerability status badge
<a href="https://laskyr.com/plugins/cm-on-demand-search-and-replace"><img src="https://laskyr.com/plugins/cm-on-demand-search-and-replace/badge.svg" alt="CM Search And Replace vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit