Plugins · clickcease-click-fraud-protection · data as of 2026-11-04
Is ClickCease Click Fraud Protection safe? Known vulnerabilities and latest version
- Latest version
- 3.3.1
- Last updated
- 2026-11-01
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Protect your website and ad campaigns from bots, competitors, and click fraud with ClickCease's advanced fraud prevention and real-time monitoring. — by eranfl
What to do
- Update to the latest version (3.3.1). Anything older than 3.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get clickcease-click-fraud-protection --field=version shows what you run; wp plugin update clickcease-click-fraud-protection updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-119509 · published 2026-11-03
Missing authorization check in ClickCease Click Fraud Protection (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in eranfl ClickCease Click Fraud Protection clickcease-click-fraud-protection allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ClickCease Click Fraud Protection: from n/a through 3.3.0.
medium 4.3 CVE-2023-6810 · published 2024-05-07
Missing authorization check in ClickCease Click Fraud Protection (3.2.4 and older)
- Affected
- 3.2.4 and older
- Fixed in
- 3.2.12 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ClickCease Click Fraud Protection plugin for WordPress is vulnerable to unauthorized access of data due to an improper capability check on the get_settings function in all versions up to, and including, 3.2.4. This makes it possible for authenticated attackers, with author access and above, to retrieve the plugin's configured API keys.
medium 4.3 CVE-2024-33678 · published 2024-04-26
Cross-site request forgery (CSRF) in ClickCease Click Fraud Protection (3.2.7 and older)
- Affected
- 3.2.7 and older
- Fixed in
- 3.2.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in eranfl ClickCease Click Fraud Protection clickcease-click-fraud-protection.This issue affects ClickCease Click Fraud Protection: from n/a through <= 3.2.7.
Recent activity
- 2026-11-01 — latest release on wordpress.org (3.3.1).
- 2026-11-03 — Missing authorization check disclosed (CVE-2026-119509), fixed in 3.3.1.
- 2024-05-07 — Missing authorization check disclosed (CVE-2023-6810), fixed in 3.2.12.
- 2024-04-26 — Cross-site request forgery (CSRF) disclosed (CVE-2024-33678), fixed in 3.2.8.
Get an email when ClickCease Click Fraud Protection has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ClickCease Click Fraud Protection (clickcease-click-fraud-protection) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/clickcease-click-fraud-protection (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/clickcease-click-fraud-protection"><img src="https://laskyr.com/plugins/clickcease-click-fraud-protection/badge.svg" alt="ClickCease Click Fraud Protection vulnerability status"></a>