Plugins · click-to-chat-for-whatsapp · data as of 2026-11-01
Is Click to Chat safe? Known vulnerabilities and latest version
- Latest version
- 4.46
- Last updated
- 2026-10-30
- Active installs
- 600,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
WhatsApp Chat🔥. Let's make your Web page visitors contact you through 'WhatsApp', 'WhatsApp Business'. Add matching Widget✅ — by HoliThemes
What to do
- Update to the latest version (4.46). Anything older than 4.45 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get click-to-chat-for-whatsapp --field=version shows what you run; wp plugin update click-to-chat-for-whatsapp updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.1 CVE-2026-92097 · published 2026-10-14
Remote code execution in Click to Chat (4.44 and older)
- Affected
- 4.44 and older
- Fixed in
- 4.45 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Click to Chat for WhatsApp plugin for WordPress is vulnerable to Arbitrary Shortcode Execution in versions up to, and including, 4.44 This is due to the greetings_dialog() function building the {url} template placeholder from a sanitize_text_field()-filtered $_SERVER['REQUEST_URI'] on archive pages and then passing the substituted greeting content to do_shortcode() in the greetings-1 and greetings-2 templates, without stripping shortcode delimiters. Because wp_kses() runs against main_content BEFORE the {url} substitution, the attacker-controlled URL bytes reach do_shortcode() unfiltered. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes registered by WordPress core, the active theme, or any other plugin (e.
NVD CVE-2026-92097Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-7795 · published 2026-06-06
Stored cross-site scripting (XSS) in Click to Chat (4.39 and older)
- Affected
- 4.39 and older
- Fixed in
- 4.40 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Click to Chat – WA Widget plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the [chat] shortcode 'num' parameter in all versions up to, and including, 4.38. This is due to insufficient escaping when embedding user-supplied shortcode attribute values inside JavaScript string literals that are then placed in HTML event-handler attributes. The CCW_Shortcode::shortcode() function applies esc_attr() to the 'num' parameter (line 157), which converts single quotes to the HTML entity '. This entity-encoded value is then interpolated directly into a JavaScript window.open() call string delimited by single quotes (line 194/221), and that complete string is placed verbatim into an HTML onclick attribute in the style template files (e.g., sc-style-1.php line 6). Because browsers HTML-decode event attribute values before executing the embedded JavaScript, the ' entities are decoded back to literal single quotes at runtime, allowing the injected payload to break out of the JavaScript string context and execute arbitrary code. This makes it possible for authenticated attackers with Contributor-level access and above to inject arbitrary web scripts into pages that will execute whenever a user clicks the WhatsApp chat button rendered by the [chat] shortcode.
NVD CVE-2026-7795Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2025-5336 · published 2025-06-14
Stored cross-site scripting (XSS) in Click to Chat (4.22 and older)
- Affected
- 4.22 and older
- Fixed in
- 4.26 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Click to Chat plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘data-no_number’ parameter in all versions up to, and including, 4.22 to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-5336Wordfence advisoryCode change (fix)wordpress.orgPlugin source
high 8.8 CVE-2024-3849 · published 2024-05-02
File inclusion in Click to Chat (3.35 and older)
- Affected
- 3.35 and older
- Fixed in
- 4.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Click to Chat – HoliThemes plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 3.35. This makes it possible for authenticated attackers, with contributor access or above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.
NVD CVE-2024-3849Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2022-4480 · published 2023-01-16
Stored cross-site scripting (XSS) in Click to Chat (older than 3.18.1)
- Affected
- older than 3.18.1
- Fixed in
- 3.18.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Click to Chat WordPress plugin before 3.18.1 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Recent activity
- 2026-10-30 — latest release on wordpress.org (4.46).
- 2026-10-14 — Remote code execution disclosed (CVE-2026-92097), fixed in 4.45.
- 2026-06-06 — Stored cross-site scripting (XSS) disclosed (CVE-2026-7795), fixed in 4.40.
- 2025-06-14 — Stored cross-site scripting (XSS) disclosed (CVE-2025-5336), fixed in 4.26.
Get an email when Click to Chat has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Click to Chat (click-to-chat-for-whatsapp) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/click-to-chat-for-whatsapp (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/click-to-chat-for-whatsapp"><img src="https://laskyr.com/plugins/click-to-chat-for-whatsapp/badge.svg" alt="Click to Chat vulnerability status"></a>