Skip to content
Laskyr

Plugins · clearfy · data as of 2026-11-04

Is Clearfy Cache safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.3)

As of 2026-11-04. 8 issues are on record for older versions; version 2.4.3 or newer fixes all of them that state a fix.

Latest version
2.4.3
Last updated
2026-07-23
Active installs
40,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Optimize and tweak WordPress by disable unused features. Improve performance, SEO and security using Clearfy — super easy, fast and zero code. — by Creativemotion

What to do

  1. Update to the latest version (2.4.3). Anything older than 2.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get clearfy --field=version shows what you run; wp plugin update clearfy updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-16295 · published 2026-08-04

Missing authorization check in Clearfy Cache (older than 2.4.3)

Affected
older than 2.4.3
Fixed in
2.4.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Clearfy Cache WordPress plugin before 2.4.3 does not perform a capability check in one of its admin-page dispatch paths, allowing any authenticated user such as a Subscriber to render admin-only settings pages and disclose their contents, including administrative nonces, while the canonical page URL correctly restricts access.

NVD CVE-2026-16295WPScan advisory

medium 4.7 CVE-2026-16296 · published 2026-08-04

Open redirect in Clearfy Cache (older than 2.4.3)

Affected
older than 2.4.3
Fixed in
2.4.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Clearfy Cache WordPress plugin before 2.4.3 does not validate the redirect target in its Cyrlitera old-URL redirect handler, passing a decoded request URI to an unsafe redirect function, which allows unauthenticated attackers to redirect visitors to an arbitrary external URL when a non-default option is enabled.

NVD CVE-2026-16296WPScan advisory

medium 4.1 CVE-2026-16297 · published 2026-08-03

PHP object injection in Clearfy Cache (older than 2.4.3)

Affected
older than 2.4.3
Fixed in
2.4.3
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Clearfy Cache WordPress plugin before 2.4.3 does not restrict the classes allowed when unserializing settings-import data, allowing users with administrator access to perform PHP Object Injection attacks, which may lead to remote code execution when a suitable gadget chain is present in the environment.

NVD CVE-2026-16297WPScan advisory

medium 4.3 CVE-2025-13749 · published 2026-01-09

Cross-site request forgery (CSRF) in Clearfy Cache (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.4.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.4.0. This is due to missing nonce validation on the "wbcr_upm_change_flag" function. This makes it possible for unauthenticated attackers to disable plugin/theme update notifications via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-13749Wordfence advisoryCode change (fix)research.cleantalk.org

medium 4.3 CVE-2024-13337 · published 2025-04-12

Cross-site request forgery (CSRF) in Clearfy Cache (2.3.2 and older)

Affected
2.3.2 and older
Fixed in
2.3.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.3.2. This is due to missing or incorrect nonce validation on the 'setup-wbcr_clearfy' page. This makes it possible for unauthenticated attackers to update the plugins settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2024-13337Wordfence advisoryCode change (fix)github.dev

medium 4.3 CVE-2024-13338 · published 2025-04-12

Cross-site request forgery (CSRF) in Clearfy Cache (2.3.1 and older)

Affected
2.3.1 and older
Fixed in
2.3.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Clearfy Cache – WordPress optimization plugin, Minify HTML, CSS & JS, Defer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.3.1. This is due to missing or incorrect nonce validation on the wclearfy_cache_delete functionality . This makes it possible for unauthenticated attackers to clear the cache via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2024-13338Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-43260 · published 2024-11-01

Missing authorization check in Clearfy Cache (2.2.4 and older)

Affected
2.2.4 and older
Fixed in
2.2.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Creative Motion Clearfy Cache allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Clearfy Cache: from n/a through 2.2.4.

NVD CVE-2024-43260Patchstack advisory

medium 4.3 CVE-2024-34806 · published 2024-05-17

Cross-site request forgery (CSRF) in Clearfy Cache (2.2.1 and older)

Affected
2.2.1 and older
Fixed in
2.2.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Creative Motion Clearfy Cache.This issue affects Clearfy Cache: from n/a through 2.2.1.

NVD CVE-2024-34806Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Clearfy Cache vulnerability status badge
<a href="https://laskyr.com/plugins/clearfy"><img src="https://laskyr.com/plugins/clearfy/badge.svg" alt="Clearfy Cache vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit