Plugins · classic-editor · data as of 2026-11-01
Is Classic Editor safe? Known vulnerabilities and latest version
- Latest version
- 1.7.0
- Last updated
- 2026-05-28
- Active installs
- 8+ million
- Known issues on record
- 0
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 5.2.4+
Enables the previous "classic" editor and the old-style Edit Post screen with TinyMCE, Meta Boxes, etc. Supports all plugins that extend this screen. — by WordPress.org
What to do
- Update to the latest version (1.7.0). Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get classic-editor --field=version shows what you run; wp plugin update classic-editor updates it.
Known vulnerabilities
None on record in the sources we check, as of 2026-11-01.
Recent activity
- 2026-05-28 — latest release on wordpress.org (1.7.0).
Get an email when Classic Editor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Classic Editor (classic-editor) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/classic-editor (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/classic-editor"><img src="https://laskyr.com/plugins/classic-editor/badge.svg" alt="Classic Editor vulnerability status"></a>