Skip to content
Laskyr

Plugins · ci-hub-connector · data as of 2026-11-04

Is CI HUB Connector safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.108)

As of 2026-11-04. 1 issue is on record for older versions; version 1.2.108 or newer fixes all of them that state a fix.

Latest version
1.2.108
Last updated
2026-09-08
Active installs
100+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.6+

Work better with images, text and video by connecting your WordPress Site to your cloud storage or the stock media platform of your choice. — by CI HUB Connector

What to do

  1. Update to the latest version (1.2.108). Anything older than 1.2.108 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ci-hub-connector --field=version shows what you run; wp plugin update ci-hub-connector updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-4353 · published 2026-04-22

Stored cross-site scripting (XSS) in CI HUB Connector (1.2.106 and older)

Affected
1.2.106 and older
Fixed in
1.2.108 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The CI HUB Connector plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' attribute of the `cihub_metadata` shortcode in all versions up to, and including, 1.2.106 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-4353Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CI HUB Connector vulnerability status badge
<a href="https://laskyr.com/plugins/ci-hub-connector"><img src="https://laskyr.com/plugins/ci-hub-connector/badge.svg" alt="CI HUB Connector vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit