Skip to content
Laskyr

Plugins · checkout-upsell-and-order-bumps · data as of 2026-11-04

Is UpsellWP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.10)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2.6 or newer fixes all of them that state a fix.

Latest version
2.2.10
Last updated
2026-09-15
Active installs
5,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Best WooCommerce Upsell plugin to create checkout upsells, cross-sells, order bumps and frequently bought together bundles to increase AOV. — by flycart

What to do

  1. Update to the latest version (2.2.10). Anything older than 2.2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get checkout-upsell-and-order-bumps --field=version shows what you run; wp plugin update checkout-upsell-and-order-bumps updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.6 CVE-2026-32459 · published 2026-03-13

SQL injection in UpsellWP (2.2.4 and older)

Affected
2.2.4 and older
Fixed in
2.2.5
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in flycart UpsellWP checkout-upsell-and-order-bumps allows Blind SQL Injection.This issue affects UpsellWP: from n/a through <= 2.2.4.

NVD CVE-2026-32459Patchstack advisory

medium 4.3 CVE-2026-25419 · published 2026-02-19

Missing authorization check in UpsellWP (2.2.5 and older)

Affected
2.2.5 and older
Fixed in
2.2.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in flycart UpsellWP checkout-upsell-and-order-bumps allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects UpsellWP: from n/a through <= 2.2.5.

NVD CVE-2026-25419Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
UpsellWP vulnerability status badge
<a href="https://laskyr.com/plugins/checkout-upsell-and-order-bumps"><img src="https://laskyr.com/plugins/checkout-upsell-and-order-bumps/badge.svg" alt="UpsellWP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit