Skip to content
Laskyr

Plugins · checkout-for-paypal · data as of 2026-11-04

Is Checkout for PayPal safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.49)

As of 2026-11-04. 4 issues are on record for older versions; version 1.0.47 or newer fixes all of them that state a fix.

Latest version
1.0.49
Last updated
2026-10-09
Active installs
500+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

Accept PayPal payments on WordPress with a simple PayPal Checkout integration. No shopping cart or WooCommerce required. — by Noor Alam

What to do

  1. Update to the latest version (1.0.49). Anything older than 1.0.47 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get checkout-for-paypal --field=version shows what you run; wp plugin update checkout-for-paypal updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-32387 · published 2026-03-13

Missing authorization check in Checkout for PayPal (1.0.46 and older)

Affected
1.0.46 and older
Fixed in
1.0.47
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Noor Alam Checkout for PayPal checkout-for-paypal allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Checkout for PayPal: from n/a through <= 1.0.46.

NVD CVE-2026-32387Patchstack advisory

medium 6.5 CVE-2025-39572 · published 2025-04-16

Stored cross-site scripting (XSS) in Checkout for PayPal (1.0.38 and older)

Affected
1.0.38 and older
Fixed in
1.0.39
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Noor Alam Checkout for PayPal checkout-for-paypal allows Stored XSS.This issue affects Checkout for PayPal: from n/a through <= 1.0.38.

NVD CVE-2025-39572Patchstack advisory

medium 6.4 CVE-2024-13398 · published 2025-01-17

Stored cross-site scripting (XSS) in Checkout for PayPal (1.0.32 and older)

Affected
1.0.32 and older
Fixed in
1.0.39 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Checkout for PayPal plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'checkout_for_paypal' shortcode in all versions up to, and including, 1.0.32 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13398Wordfence advisoryCode change (fix)

medium 5.4 CVE-2022-3983 · published 2022-12-19

Stored cross-site scripting (XSS) in Checkout for PayPal (older than 1.0.14)

Affected
older than 1.0.14
Fixed in
1.0.14
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Checkout for PayPal WordPress plugin before 1.0.14 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks

NVD CVE-2022-3983WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Checkout for PayPal vulnerability status badge
<a href="https://laskyr.com/plugins/checkout-for-paypal"><img src="https://laskyr.com/plugins/checkout-for-paypal/badge.svg" alt="Checkout for PayPal vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit