Plugins · checkout-field-editor-and-manager-for-woocommerce · data as of 2026-11-04
Is Checkout Field Editor for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 3.0.8
- Last updated
- 2026-10-06
- Active installs
- 20,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
WooCommerce checkout field editor and manager helps to manage checkout fields in WooCommerce — by acowebs
What to do
- Update to the latest version (3.0.8). Anything older than 3.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get checkout-field-editor-and-manager-for-woocommerce --field=version shows what you run; wp plugin update checkout-field-editor-and-manager-for-woocommerce updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.9 CVE-2026-66475 · published 2026-07-27
Cross-site scripting (XSS) in Checkout Field Editor for WooCommerce (3.0.5 and older)
- Affected
- 3.0.5 and older
- Fixed in
- 3.0.6 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Shop manager Cross Site Scripting (XSS) in Checkout Field Editor for WooCommerce – Checkout Manager <= 3.0.5 versions.
Recent activity
- 2026-10-06 — latest release on wordpress.org (3.0.8).
- 2026-07-27 — Cross-site scripting (XSS) disclosed (CVE-2026-66475), fixed in 3.0.6.
Get an email when Checkout Field Editor for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Checkout Field Editor for WooCommerce (checkout-field-editor-and-manager-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by acowebs (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/checkout-field-editor-and-manager-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/checkout-field-editor-and-manager-for-woocommerce"><img src="https://laskyr.com/plugins/checkout-field-editor-and-manager-for-woocommerce/badge.svg" alt="Checkout Field Editor for WooCommerce vulnerability status"></a>